summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/django-debug-toolbar
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest6
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild52
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild (renamed from dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild)9
3 files changed, 9 insertions, 58 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index dcef6b86640c..d84a4fc78910 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,5 +1,3 @@
-DIST django-debug-toolbar-2.0.tar.gz 321249 BLAKE2B cd4f9e7d55deaf404369ba89eaffe0c730a058450c8368e39bfe3f5562019f5978ff33b93dc0463dc0fa6e6ba1047335d45997929dc3d2b576a78ff7cd5f75f0 SHA512 8440705a2e38f2c035a1dde4eb14ec829ead502cbbebcae46889e26877c0843389107bf14249afe9742638c4880b362fd699aed935e271bc1ade8f0a54bfea46
-DIST django-debug-toolbar-2.1.tar.gz 321132 BLAKE2B 4765a25bd7aa2578c65cd0918bf47de047e131deb896cdd7b80111e9628e4f7c39ad6dc84fc4114310fb1a8195fea263810b279e8b19b6e621879b8eb2961f82 SHA512 3cfd11b28ec6573977a0476388e8f4d63441c5b390fe974294bc059a83fc95a44c3c8df18a549403756f7929181750aec51d70b38cfe3bce1d40ba24e6b72e9d
-EBUILD django-debug-toolbar-2.0.ebuild 1297 BLAKE2B 5aedb07036e862da7777f4ca3c7b517b6d2bcc86e410022dcf820a836fe9aa789c1c421435bb68cf156c6fd142cee0138d985cd4cfafcc73f2f7a0fd93a7fbce SHA512 0eae2860812de37dfd53874c046d61e9969530b77e5c71999f79630020467b7a9cd9284250d26994f192c996329c48a3ab0c5f1a114f2cfd5df9c5c1b3974e6c
-EBUILD django-debug-toolbar-2.1.ebuild 1307 BLAKE2B de77e8a50b2118806dc6eea1b0736cff6bdadd37fa21e806e4885c651e2547176561c33295c06dfc84443ae63a44808ac6580b369f707cef620087297106859b SHA512 b01dc0e2a605148149cee3137b72d5567b8af6560a21c67fe6a2ff3b1268859f76c751d0fd082874e400a0dabd65bc277f7af63ee43a6cbbd6fbcb23f7782232
+DIST django-debug-toolbar-2.2.tar.gz 322475 BLAKE2B cff55a26f4d95353edff3d7f678a052c262636afc94307e22e4d9dc1b6bbe3c0bc1a4997c4904a397de97218b462d52e67ac0f80bb05de7736cb278c7dca58ee SHA512 5cd9e50852bd7efeb83879c5e9fe10fe6df5087b746e9cb2a0e13e66b3fe0a815a6eaea4b273258e7e682149bc29ad8979268d2be263539c522624e3f16aa5f5
+EBUILD django-debug-toolbar-2.2.ebuild 1368 BLAKE2B 7f075599c0db2cea461d893a80a382345835a40512be9f8ccc0336093c277afd4bb72de7730e84a02b72082495e8527d3d8eb993bd92f6604fe49eb67b706375 SHA512 8fc887526e125f289dc2aa9825ca84f6f66cf348ff38cd1fe8004ca469cad17d6f17ca8378b1191b7b3f42f922a787ff1b9abc5983c2b604b609ae4c44e83cb2
MISC metadata.xml 356 BLAKE2B c0d02bcf9ab38d7939a3edaf8eca080283ccee6f95f1e04ac96ce5870845e6a84d6672d6ac923c74d18c340326bca379691946aac7a51bdee8d6f4adcb45a50e SHA512 12686662e852b0283d2212f0db83c832c1248723a7cd751990e43b1641ddbad2cc2c71c17ac4704c01beec9a9366fc726504c10e9a9e56456b544a800cfa7847
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
deleted file mode 100644
index 4de469ee23f2..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A configurable set of panels that display debug information"
-HOMEPAGE="
- https://pypi.org/project/django-debug-toolbar/
- https://github.com/django-debug-toolbar/django-debug-toolbar/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/django-1.11[${PYTHON_USEDEP}]
- >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # Prevent non essential d'loading by intersphinx
- sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-
- # This prevents distutils from installing 'tests' package, rm magic no more needed
- sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild
index 353fa1f7bd7a..2874326eb203 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-2.1.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild
@@ -20,7 +20,7 @@ IUSE="doc examples"
RDEPEND="
>=dev-python/django-1.11[${PYTHON_USEDEP}]
- >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
@@ -47,6 +47,11 @@ python_test() {
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( example/. )
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
distutils-r1_python_install_all
}