summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
commit3023707d355581e5dc6945aa9c8f4d59e508a8b5 (patch)
tree5bf569d557ba145002d922f72eadde17410572d4 /dev-python/django-debug-toolbar
parent4e777c0133d093c9c8b992c92e0f244e2055bf71 (diff)
gentoo auto-resync : 05:05:2023 - 11:30:40
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index ddb7d6ed5924..4bebd51ead96 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,5 @@
DIST django-debug-toolbar-3.8.1.gh.tar.gz 269449 BLAKE2B e93da38cdb6aa160dab65816858b1f7ca532ad22617e1859669fc508472086a93807aa874fde92ef95e6e33268a2f14de19d1498a15ca92ec89a9f8b3bf2a323 SHA512 4fa7b3fa3f9767cf1edba26c9de625675bcb1bafcb6d88d7ab95c331da6865f5c3cdb25848a6d2f4befdf9b2e65db4123b496f06a1b2e39eb3ee71f0c3384d26
+DIST django-debug-toolbar-4.0.0.gh.tar.gz 265429 BLAKE2B ee444246fc71bef989451bbb53e35d2be072ec9b219dfc9a9018fe736a9b750d271adc5af040374cfcb6a8e4ed26260640a952308576997e2bf42da3aec9fec4 SHA512 6a6d586a9a3c87811193c19a5fd5cb425700573a1ece71ed13d76caba208da14a1beb32e2dbc69e8ea7f09d52f42bf3b71f9608f91cc51ec41ab92558bf7e2c9
EBUILD django-debug-toolbar-3.8.1.ebuild 639 BLAKE2B 75381d8a8d62353f9a9cf2738ff0fcdb8392441e49792ffa3887d9f1e9b9803716e845977f4e4c3ae7887ae8fe1ea44910b3564ff412ed0a2eb5d0e216adbc10 SHA512 0473ab856885182acc1d7c5b988a9827a48d36cc83f996bc242d8cb96bd87639673d801906a9d7707f9df0822e9b8b41ff4fa61d82af72141814e13196521d56
+EBUILD django-debug-toolbar-4.0.0.ebuild 739 BLAKE2B f76c3e5bbc2d2f9235980bab86e525054dc2993ee42e3c08a0e85594d276d92ac9ce3733bf31c768ee6bb1d75dc4c4bc2e3d158d74d1b055258cb313506301aa SHA512 206f9798dabe1b44983f04deb8b2685c880854f9083299e9eae19c435ed9feaedacd041960822d4fde98bf4a99b887b189115f3f47385f5560a8fe0d39aac455
MISC metadata.xml 400 BLAKE2B 5e173b9872626f2eb14b25d4b0271f339576fefc19a28f3ad8a8358bd0cd07ef6af0a268f7aa0f403ffb6ffd9527415bc173f7c5fb516bdb2e201883a8ec7390 SHA512 64e2fd8932cc6795a7d72aa37d8634f17556f1141c1bef1abddca2d56fa67f8500861b53a2698a96bf8adf66e7a991108b59fce55c710cd6cc3963ee3a35241e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild
new file mode 100644
index 000000000000..18838ad2c3ec
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+# no tests in sdist, as of 4.0.0
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}