summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild')
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
new file mode 100644
index 000000000000..f64d97c58419
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}