summaryrefslogtreecommitdiff
path: root/dev-python/django-crispy-forms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
commit5a2a5572ac35843b9cd1c9369bd96e117647d24f (patch)
tree4f3b96f8834f6c6a9742a7a7e9f3453240fc5cbe /dev-python/django-crispy-forms
parent01f09076452fe45dac176dc2c4fff1ba81f3b5e0 (diff)
gentoo auto-resync : 16:10:2023 - 09:55:38
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest2
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index a192afeacb4a..46e9c222473e 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1,3 +1,5 @@
DIST django-crispy-forms-2.0.gh.tar.gz 273743 BLAKE2B 4169c4f77ddd0dd9f8786abd71ad762f645283555f250861f32b874fb9e189d4ca174285ee39b51bc5f0c0e8c2e83c2e00c34398c51ede65438a1c6b8a17c3ee SHA512 8b6f5b35cb90837b7cd6a64ed74afe6a19a80f287f66d0a139811990524e1a48d4d7c01e61fb7d303958522c47458d0aa0008a3d6c147f7d03dc790e53a80592
+DIST django-crispy-forms-2.1.gh.tar.gz 274397 BLAKE2B 3f38830f370efde04494add3ddd2ce7f4a04b032b9aad770ba30885ed2b3a14cff3c748fa299041c9c1d7007b30eb55c96a46fe496c0432b187ae72879d4240e SHA512 703f353adc272905b4d5ebe21ea54e3016a3889703bf406dfdf92638dac2e6f536cf1bc16022be6a442f7dfa962ff17746edea591cf80c2be9440d9bb50a9dcc
EBUILD django-crispy-forms-2.0-r1.ebuild 695 BLAKE2B 3111a50692404e13da9787a80acbc1a2c0441e0081797d40b1d608ea1ef04b5bba1aea070a737cd8f1ab7630fdadaa0d8ddd4ee7745cfde676550557ed451754 SHA512 d65e11eb8cdece9f7f5b2d6b428075cb5987a76598e103b423bbcb9b19ae935021ef3da251eb6062ef3001019abaed90a36604b6ab31fa348e332efdf5cced5a
+EBUILD django-crispy-forms-2.1.ebuild 769 BLAKE2B 73d4218ad6ce1c07f1f6658921b4ead263dfe6f1e5f51ab6eb6a56a33228001587984e932ed64a5421c24b8d984f767ea86b89bc9c39c9d521fcb01ae9582ceb SHA512 5a517b1b3cbf237fd987b5d2705297c6b1711307149522a4a50bedc9264805e9804cffb990ea47df349b5b0e49ee8707dbde6fb5cfc8a96c730f62003b09acbe
MISC metadata.xml 409 BLAKE2B d9663843245601ca8675fd522ca3b4150c36611874fb852f3c0c7bf68ec9595cb45ef66c293d658c13670f18bca6949a2747cffbbf819b55cd9b30ca6340bfba SHA512 2b1091cac748a00099f3a1685150bc8dfdf252b18b7e5c2fc17a8ca5054ec7ac0e72286dba872ead0354b4bae02cc3c410a5d05828f9dc257919526077bffc8d
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild
new file mode 100644
index 000000000000..69f2d844079a
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/django-crispy-forms/
+ https://pypi.org/project/django-crispy-forms/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/django-crispy-forms/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap3[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest