summaryrefslogtreecommitdiff
path: root/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild')
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
new file mode 100644
index 000000000000..083636da4530
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-crispy-forms/
+ https://github.com/maraujop/django-crispy-forms
+ https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Seems to be incompletely packed
+RESTRICT=test
+
+python_test() {
+ DJANGO_SETTINGS_MODULE=crispy_forms.tests.test_settings py.test crispy_forms/tests || die
+}