summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /dev-python/django-configurations
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest4
-rw-r--r--dev-python/django-configurations/django-configurations-2.4.1.ebuild44
-rw-r--r--dev-python/django-configurations/django-configurations-2.5.ebuild2
3 files changed, 2 insertions, 48 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index b5e04c498c29..3c234373cbbd 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,5 +1,3 @@
-DIST django-configurations-2.4.1.tar.gz 42952 BLAKE2B 3ed30642b256a648ab5932edd9b2cb5b2a82e69bb1107a5c2bd20d230cbb598f21eddcf52956bf80d6fe3c6e6336c70dfadf2fc5a646dcd32782abc782fe8e32 SHA512 ab35216b326d50d779344efa915d516ffa4a1d5e627c77b27071f6d51c54ea367a0f7ec5a7b768cabd69929499dfeb3e5719ba8fbe690f6854d92ee45a04bf1d
DIST django-configurations-2.5.tar.gz 43152 BLAKE2B 35976466132f9b78a031955c891733cb0a01f20d39d53708ed5100492b3a1963e50228f3175437f54201fb6d992312c641e08562a85cf57cb089f2c7678101e7 SHA512 a6e3f301bf6123234245a5fe88f4b0eecfc021230c593d2864a969560d52c70b6932c0fac64cd83f21fb06b83821d37320181f0601450d6f3cd4e4b06c4ae9f5
-EBUILD django-configurations-2.4.1.ebuild 1099 BLAKE2B 15756f69fe4617139e65b6e9d4ec8ad0e36c0a0567469251674314f26fbdcd97c818463f6c3064ab7225f1cbf1d6ed949e9ddc14f80226891648c5943718cf69 SHA512 9e310244a8b3cb63c83b159942a98333264f119a7ec3427219cb02379f0e932718061a2fc848e8f91d3f3ca775cc9859dc1f65e08e6c2b2f7658487a9f49e3ac
-EBUILD django-configurations-2.5.ebuild 1104 BLAKE2B 938c0bdc6cbf0b4a67959788a4a8ed1349d76764a7137e0b98078af7ceaa2fb1a3cc9e6c95965e4cfed3bed091947b33bd68adb2b5cfa590aa70e85ec47484df SHA512 45afc12ede5232277df64db486ff1fb26e74cf9df0eae9cbca6cfde2015a8064c5509e554495c15e06048274e50442dc1aec0641c4ae14e9e954a3c172bf6c3d
+EBUILD django-configurations-2.5.ebuild 1100 BLAKE2B e48bd277bc106e3d2fa417958007a22272dd880d132442f47124407cad050546185acb3fd8746945a289d1a84b00684c1784ef2f46cd551e50e1c0889a5749de SHA512 f903b4cd0144c5ae73c5a26661ff68616dc81fed838d971cb103b51a9f2113e5a6a508158d06219522855869d0d098a9ff11a72c67ecb06f047e41586f6e022b
MISC metadata.xml 397 BLAKE2B 704a6d38af3df4b99f24a394dce870ce4f3e1e16c2a30b87ab25ab4b3603451651db062d2aca6669b410bf5350b0edc7b4848ef55bc60c69edc3aedeb8a7c0fc SHA512 a37389a326e763452c7ea138da3eb33dad53bbce24fbd9229e58020063d4e726e68e482500c87238bc0c53b9ee335f93f2d89f39e7ce3e2a087175a2393c66e4
diff --git a/dev-python/django-configurations/django-configurations-2.4.1.ebuild b/dev-python/django-configurations/django-configurations-2.4.1.ebuild
deleted file mode 100644
index 0e47cd0c0c88..000000000000
--- a/dev-python/django-configurations/django-configurations-2.4.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A helper for organizing Django settings"
-HOMEPAGE="
- https://pypi.org/project/django-configurations/
- https://github.com/jazzband/django-configurations/
- https://django-configurations.readthedocs.io/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/django-cache-url[${PYTHON_USEDEP}]
- dev-python/dj-database-url[${PYTHON_USEDEP}]
- dev-python/dj-email-url[${PYTHON_USEDEP}]
- dev-python/dj-search-url[${PYTHON_USEDEP}]
- )
-"
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings.main
- local -x DJANGO_CONFIGURATION=Test
- PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/django-configurations/django-configurations-2.5.ebuild b/dev-python/django-configurations/django-configurations-2.5.ebuild
index 40507eae52db..051a95a4e16f 100644
--- a/dev-python/django-configurations/django-configurations-2.5.ebuild
+++ b/dev-python/django-configurations/django-configurations-2.5.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"