summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/django-configurations
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest2
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index 0208bdaabd4d..e448b5541532 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,3 +1,5 @@
DIST django-configurations-2.2.gh.tar.gz 41909 BLAKE2B 4107e37a694d4c9670f855886d870c7aea30e9b95788a6c09f6fb3c913d3ffc4d17ed250264ce9ff0408856787b4768cda67eecf26c135ccb338ffda7530fd41 SHA512 9c53811016c20ae4dedbb9e1951b45440b656fad2fb9544e94bbbabb65a5883846ee063647f107ac57c08e54db71206b89903ee1d02cbfc0c8d3dafe7520e5a2
+DIST django-configurations-2.3.1.gh.tar.gz 38288 BLAKE2B f9d4322ad3e1fe839c6cc9d3e8eee31d0f3bbd48859f8e49b5fa72a3984517b77248278c42b4a709f1a5965cff3af336c5fea7323004b41fcc15a4ee40175524 SHA512 0d3df709fe306fba1e85d03e5ce16c954a796327d857717e3e802fc717d94f7aa5255a8422e27991faaade31c29bc90e3e05923609e68893784996ca87ca93ed
EBUILD django-configurations-2.2.ebuild 1447 BLAKE2B cbf8aa50de4f1de3851af4e6de43393df6f37c622d8eaa6d8d0f4e77d62a8c69a118e8cec828e47f89418ec640470637295e4ecf6bb098930a2b2f8b444482b1 SHA512 3582413d81ff0b9c624c06f9520b524ef8bc2241c48b7ffc6f75091929b110af6294b27e5c7a5352d2b64771d8fe6cc22a696e3a65dd92c1c4ee0aa46430dddc
+EBUILD django-configurations-2.3.1.ebuild 1152 BLAKE2B 1cfc17a80f795f936f8975f82d14863daa6a713bf03859cabb19ab8d6f0e49903d8ae81b30420b0d73104097ba4a51b933b997b50fee396ed70161dfd9a4887a SHA512 8d72427779b53963eda0ac34984487cd877c6bbb27edb413f3e28702fe684a1c3c977dc7284ac5d5c080907acde2254ce40f35f8184c31da084aa66bcab9583f
MISC metadata.xml 219 BLAKE2B f7cf6cd41e0433b323b2c16caf31baef1c0b5ea00980018722e5fae803f92216e39343892928605454b0c756e121929eace02b4925a6bd7f10421e91a1845357 SHA512 27c6aca9eb36b7d427c10b6daedc4bc6c0d744fb464e5322ef6823073bb9be648a60ba2fff5f855282a5a5a3da3ce379d9419cde175d462f1fa443ff6b3a4bdf
diff --git a/dev-python/django-configurations/django-configurations-2.3.1.ebuild b/dev-python/django-configurations/django-configurations-2.3.1.ebuild
new file mode 100644
index 000000000000..7363d23fc599
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ distutils_install_for_testing
+ django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}