summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
commitad77dc19e91d2c023f80e11e8974536d80e3a743 (patch)
tree42bb312ab0eb61fd94103e3eddb65b134f6be5a4 /dev-python/django-configurations
parent6de28447d66e6c47ee682740b840cdb67244d4b1 (diff)
gentoo auto-resync : 05:04:2023 - 11:25:00
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest2
-rw-r--r--dev-python/django-configurations/django-configurations-2.4.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index cf0047c463c2..8f2b4e20a218 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,3 +1,5 @@
+DIST django-configurations-2.4.1.tar.gz 42952 BLAKE2B 3ed30642b256a648ab5932edd9b2cb5b2a82e69bb1107a5c2bd20d230cbb598f21eddcf52956bf80d6fe3c6e6336c70dfadf2fc5a646dcd32782abc782fe8e32 SHA512 ab35216b326d50d779344efa915d516ffa4a1d5e627c77b27071f6d51c54ea367a0f7ec5a7b768cabd69929499dfeb3e5719ba8fbe690f6854d92ee45a04bf1d
DIST django-configurations-2.4.gh.tar.gz 38563 BLAKE2B a454cc492354c1b969a1b0389ccb21088e99af17b5056ae514b36b5c2fd7391368437093d1a075814dfb8e15ec8ce3ec3c5269d5c867b4a03a5269a533826a31 SHA512 de9793c5fce869ef77e4396dd5ea45fc57728d702383885599d3a08b16e37e0e425258aacd671ac78592df813c8fa3a08b33ad9410843f7d7976589da33592ca
+EBUILD django-configurations-2.4.1.ebuild 1103 BLAKE2B 660b411d0a888b28b63e6585aa1b5472e1198173d49c1e2f24c684c0c677c9d5c3e81d0eda22b0c3fb8e9092f60f9cb0015f53787b3dd5d224513dfc8b796f2a SHA512 8b91cd001a7e724fcdd6db4b1e0ca4c529c4218d5ea01ad07dc3380b1b91d65fd9c0244cefdc0e7a8e88d8bf259adc64109393d9d530560c588108cc71af1e9b
EBUILD django-configurations-2.4.ebuild 1178 BLAKE2B a9502c5df708ce138f75ad442197b68c4bf8bfc285d25b40b92699011a682513338ce522c28ec4e201eb7bd22db1eb35bde7d648941dbca15410b8e6c35f677b SHA512 57e546fce9320248379218d467ae98c681ac91473f2d2a39fd9134697646a1cab6d86d62723b48550d5172be018232bebb3109f3371b581c86b5943fbfb1dd24
MISC metadata.xml 397 BLAKE2B 704a6d38af3df4b99f24a394dce870ce4f3e1e16c2a30b87ab25ab4b3603451651db062d2aca6669b410bf5350b0edc7b4848ef55bc60c69edc3aedeb8a7c0fc SHA512 a37389a326e763452c7ea138da3eb33dad53bbce24fbd9229e58020063d4e726e68e482500c87238bc0c53b9ee335f93f2d89f39e7ce3e2a087175a2393c66e4
diff --git a/dev-python/django-configurations/django-configurations-2.4.1.ebuild b/dev-python/django-configurations/django-configurations-2.4.1.ebuild
new file mode 100644
index 000000000000..6f18a81241c0
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}