summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-python/django-auth-ldap
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index ea0e1c064081..8799fc2e818c 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,3 +1,5 @@
DIST django-auth-ldap-2.4.0.tar.gz 53523 BLAKE2B a8c49b4a4ecaaf31b3b9e7caca228041e110b5b418bef0a16c0fac423d929b0bc416cb83d8dd54f0f4567503ce9d09f686c936cc9d7e170d2cf93d8c124bb3d8 SHA512 acf85846ebf6bc354f6bf00f14f3436e1701f1d7a7746cc3572310f92ae93fb75ee6eff38558548d270f2e22d64aa7c0108f4cb91457a783aae76adc714b61d1
+DIST django-auth-ldap-3.0.0.tar.gz 52381 BLAKE2B 6964b36d72b365899d4dd3dc96f16b9c1f12c06ad95c7d387ec27ac6dbc38807e16fdb953e172fcde1a0d4042f318d276b780e474d9b810325e97cd601d070b7 SHA512 105885e62fd22aace2cbe291a107046109a91507ba77257b9b428e6d49fb74b6f47116f1d8325c3fc186590b00fb2b46507dc5b73333707e56d84e9a7b926d9e
EBUILD django-auth-ldap-2.4.0.ebuild 888 BLAKE2B 63e2603e90f39e3a98dfce26142f83a5cfb689ae108e55259b3c3858a271845d2de128d95aba8e0201a94d0c3b13342f4422b52fdf00a1507172d18fdf813a84 SHA512 5e3dff77fa73754acd3d33cca398dd6c35ef7fb871264201bbf2acc9014021d3d504af2af7c0ca04dfd32f4dea2a697c1612f0e3a08032698e039bab2fb849bc
+EBUILD django-auth-ldap-3.0.0.ebuild 886 BLAKE2B 06c81941e067e5f682bbc6487fc20b2c9f18a2dc3d619f6dfdf0a2701ae4aeac80c3e9aa2b09f700728c7e1ad8b15b8354bced9b9c102486c763b7c45a630fe2 SHA512 4e2d74840920b1080027a11fb0dfaba9299e8ab53ead0f5e5b682b8168319d95becf057bf6e52ef7994d9a5366802b1e5c11f28cbf079eb8ac4ea50681bfdf16
MISC metadata.xml 404 BLAKE2B 5f203773409d544e168b6be9303ff7ad455977584df34b302fec6c84993362bb3b5058984e3e7b4c413081c47f2b0ba7301e1e866fc88297f524e3920afef353 SHA512 dee72beea7aeec5097d015e83ba95cd256005545294312d9dfa80ebe52489d6d5a1ef132177d6dbcfe77ef4fa306b532c86a5de86cbb84c8f1e0a02c86617c6e
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild
new file mode 100644
index 000000000000..afb03025412d
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-3.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://github.com/django-auth-ldap/django-auth-ldap
+ https://pypi.org/project/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ django-admin test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}