summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 17:54:48 +0100
commit8679463887b182c233b55d8112534d7d7dcde08b (patch)
tree3c45a448a6022fda1b09ac5ef94b5c02ddcc9b30 /dev-python/django-auth-ldap
parente8c80f80fd116cc679f261d8bc6ee6c9bfc3f0a0 (diff)
gentoo auto-resync : 05:10:2023 - 17:54:48
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.6.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 31adf12a6ef9..c1bb8ad34121 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,5 +1,7 @@
DIST django-auth-ldap-4.4.0.tar.gz 53117 BLAKE2B 46ae8f9788c3ed12d8b3576b4335390d3bc902a3627dd5af9028c2bd49dc64eef2f31995bcf51a6d20c55400bbd3dd5f4882ecc01e8d92564a6664db743809ca SHA512 d01f40f64e0d6cd47a0efaaf3b5e6a30a399b0a3b9a6b4c6f683a8237b84076294821970bbb265f66e06b0fbec58417287188e5f09631b21f204137d003ecfd7
DIST django-auth-ldap-4.5.0.tar.gz 53642 BLAKE2B c603cda6ed2f7532d0ef5f69a64f7c3b4bd86981e561c14be7d818f044382b54ffb926687416a170ce068ec435d660da9965761db97cff28dc4d6f95511c59c5 SHA512 1606bee77a03a669eb4ccd906db26c80166f370e04749a5f340e4a07574032130d9f6af22d25d09c96319e45f6137c26928ad543ea592d3a172aea623e97550b
+DIST django-auth-ldap-4.6.0.tar.gz 53845 BLAKE2B 279f7762b858330ab4b63ebb18a8609569ea4d3c7ff1af5ce89d64d8f207445e645d33c9415c4ad289adad0ea2da9674f1ad0d316f63ef42cd6b46c3ac3d7aed SHA512 fc3945fb9cece694b63661c8565d877bdc81e012e9b4e9a8f1840bd83f6effb525e36f40e5dd5018b43d2c7c72fcdd25a5c61bf35e6f0d05e70e830f69228498
EBUILD django-auth-ldap-4.4.0.ebuild 954 BLAKE2B f00a33b6b33411dbf1c2059f1bcc1cd9a49106087c5078a71d898d6a285b960a5d009af327447cdd284d0ddfcc247a3e0bf08e48c688db6cf6510370b44c2905 SHA512 4ed0926471365d7c339261642955dd7ab64ac5a4e8f82d323a12384da4a8aae182427a0c3ceee764cf01dfb19a8ee3e0382ba46533b7abb2819ec85e34a5b4ba
EBUILD django-auth-ldap-4.5.0.ebuild 954 BLAKE2B f00a33b6b33411dbf1c2059f1bcc1cd9a49106087c5078a71d898d6a285b960a5d009af327447cdd284d0ddfcc247a3e0bf08e48c688db6cf6510370b44c2905 SHA512 4ed0926471365d7c339261642955dd7ab64ac5a4e8f82d323a12384da4a8aae182427a0c3ceee764cf01dfb19a8ee3e0382ba46533b7abb2819ec85e34a5b4ba
+EBUILD django-auth-ldap-4.6.0.ebuild 954 BLAKE2B f00a33b6b33411dbf1c2059f1bcc1cd9a49106087c5078a71d898d6a285b960a5d009af327447cdd284d0ddfcc247a3e0bf08e48c688db6cf6510370b44c2905 SHA512 4ed0926471365d7c339261642955dd7ab64ac5a4e8f82d323a12384da4a8aae182427a0c3ceee764cf01dfb19a8ee3e0382ba46533b7abb2819ec85e34a5b4ba
MISC metadata.xml 405 BLAKE2B e9d6f5ca53505cbfa7f9cd1cdc47bd58ba15ea972bdf342874c031ec151a053025b8f63a8d9c96de90ae0798e77d0db019a70d21e8746449543bfa5d91e3fec0 SHA512 453100976204f0b32042a1711d257ae76214452579d3008f403efc11cdf5e080e3663b43c1946b9da91086de580c0a8cf860fc99c00138c9d1bd4a01a5d1dcc3
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.6.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.6.0.ebuild
new file mode 100644
index 000000000000..9e1094ca449c
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}