summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-auth-ldap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest6
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild43
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild41
-rw-r--r--dev-python/django-auth-ldap/files/docs.patch18
-rw-r--r--dev-python/django-auth-ldap/metadata.xml12
5 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
new file mode 100644
index 000000000000..794428f46628
--- /dev/null
+++ b/dev-python/django-auth-ldap/Manifest
@@ -0,0 +1,6 @@
+AUX docs.patch 697 BLAKE2B 049d893d773ca447315ca5aebec808e6933dc39cc6ebb40b06291e5f80d1c7292fc7565e4ed66264eab29d36dc0b610cd6f2864d040c641d82bc921dbc8640c3 SHA512 e9f0607d6f770d451c53e851d6141cd0cdd63ee59e654eab0c3454b9f724f36086115760614470dd42e8f8afc63b018bd695cd596d2ac71530e4a5eaab379779
+DIST django-auth-ldap-1.2.2.tar.gz 131086 BLAKE2B 78f93eb24620907f5b5671972e2b80ec6e59cdc42a455c298bef4c3215616228735a0647b0646b683357bc16ea6d03488aa86626e2ad51211a382ee2d0482909 SHA512 676d1114faeb9a2956ed51c586afea7618c1bf62867d3525596599391f8327b8f22a075c4203311df88279c317ca37b9097b59e55a64330afee6eb1c5a9c9ac3
+DIST django-auth-ldap-1.2.7.tar.gz 131431 BLAKE2B 03fac590118d25ad0d9d8a3ac5dd8bb24f138f193bf27ae85d4e2776be79bb31ca7efb278fd05ca1d45976116ca7ec79ec3b510ca380dd8912ce47f1522ad348 SHA512 2ca29bdceb4b2540f7c90c9dfdfd7a02f91e72cd44ae062cebff84199dab737ee69ada56269189ec0dd70ee7916c3373acba50866280ad080c4c68dd69dffb09
+EBUILD django-auth-ldap-1.2.2.ebuild 1095 BLAKE2B 4812e2d22c451417d33e8986519c63b580e2b6e296947e1028e8c936991abd85da12ca6b34ba71902ca039b24e805879935d028ed90bd369a15c25bf41abb351 SHA512 5f7ea4e4d09077576260829640c5513428fd7355943ec2a1e93df8b5dc697090a3c3241786d33344f12f2b0b556322098c3b52513aaab7b18f8821dcc6e8dbee
+EBUILD django-auth-ldap-1.2.7.ebuild 1053 BLAKE2B 00ecb60473127200ec35f775961382d1cbcb97318ea791a24b45d8f18d13987b2240d88fe3d547b781c499f3bfe853071d9d169a0a520cb90a6926431f466ead SHA512 d83209650888a3490b20b64e24e137b487f1340b06d4057e83d550c962e573c55d15acc3700c2b15d73b5ec21ee9d0fba8b1d14e4aea5a0fea9a32b482e9a989
+MISC metadata.xml 398 BLAKE2B 89e1948a1d118a27477e02fc01d630aaf7c9199cd913a08efc5510fec05996e1aef84fbac359d09ef73a5de083b1920747928c3626afe7aa9c1c9dfa720f16c1 SHA512 e3350f6ab3d2c07965eb2c6ba1d82a929bea8e9974d8a2cdc12acde88aab50f2c20105e90e847a23e5dea5f97a7ab6a7a0c9eb75e193eb90ea5453c53eb36d41
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
new file mode 100644
index 000000000000..e35e9de678fb
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+#S="${WORKDIR}"/psagers-${PN}-80379ce59e6b
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
new file mode 100644
index 000000000000..304dfc4d0d70
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-auth-ldap/files/docs.patch b/dev-python/django-auth-ldap/files/docs.patch
new file mode 100644
index 000000000000..c4e918fac538
--- /dev/null
+++ b/dev-python/django-auth-ldap/files/docs.patch
@@ -0,0 +1,18 @@
+Avoid unwanted d'loading for un-needed ojects.inv files
+diff -ur django-auth-ldap-1.1.4.orig/docs/source/conf.py django-auth-ldap-1.1.4/docs/source/conf.py
+--- docs/source/conf.py 2013-03-10 06:01:09.000000000 +0800
++++ docs/source/conf.py 2013-05-18 23:14:35.761187583 +0800
+@@ -29,13 +29,6 @@
+ 'daldocs',
+ ]
+
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/', None),
+- 'django': ('https://docs.djangoproject.com/en/dev/',
+- 'https://docs.djangoproject.com/en/dev/_objects/'),
+- 'pythonldap': ('http://python-ldap.org/doc/html/', None),
+-}
+-
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['../_templates']
+
diff --git a/dev-python/django-auth-ldap/metadata.xml b/dev-python/django-auth-ldap/metadata.xml
new file mode 100644
index 000000000000..cff59c60de52
--- /dev/null
+++ b/dev-python/django-auth-ldap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-auth-ldap</remote-id>
+ <remote-id type="bitbucket">psagers/django-auth-ldap</remote-id>
+ </upstream>
+</pkgmetadata>