summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-27 06:16:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-27 06:16:36 +0100
commit4936e2350e0b4aae482b12c7ce02aaa3c7e64842 (patch)
tree90d2fac7757077a3f7dc724e89fb40c1e843cf0a /dev-python/django-auth-ldap
parentc23a7f2796a181331872d4c55ea25940d1386b3d (diff)
gentoo auto-resync : 27:04:2023 - 06:16:36
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.3.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 00a21800f19e..477f80ce85b9 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,3 +1,5 @@
DIST django-auth-ldap-4.2.0.gh.tar.gz 49572 BLAKE2B e33241897a2ad6ec3cefe4d8bc6cfea322f478b3db7c2e8b7726b55f9e030f10ae25ee049842322f11939523df06af81a57122d4d3c8115416a253672c43dd39 SHA512 a37500c850b3cf49d6bc7324d721c05279570972547ebd69521033e4cd6aa340948829edb3ae94d3280a8142a42d88ce77f85bf4a8c9f32753a860881b3c5d90
+DIST django-auth-ldap-4.3.0.tar.gz 53474 BLAKE2B b3f74739fd195b7a2e2cc785fa6493feaef8917b8473fad386da1569a158f13d7c765a32bd0d83ba02d20d7b50e845d3a5cda8b5fbbf5524576c62b84690705b SHA512 6a7826af60087a25970c6ae96b9bce40212cdfbe5e2d2ee0d903ff53f02edcd361eb56a0c5db9406e8525ee6be86e18d5c13db7e4ae6f2dd5d0adc7c593a8117
EBUILD django-auth-ldap-4.2.0.ebuild 1080 BLAKE2B df342b857dfa9f7205b9634ec100a26a59952590c7f7ee7a03fbe9bed88606e4611b4911f43abd92d97a6e7efd243d63c49d20564d1f845238fb9d3bcd33b91b SHA512 18b3dc69fd7d0126d7a5367fe0bd8b880428ba21f109da9c83e719187ee139a75834da7b52b50f065ebc694dc4f6a97297e9c261d433e26f1acbd5bc0a9af790
+EBUILD django-auth-ldap-4.3.0.ebuild 953 BLAKE2B b68efd1d002d8fec3e3d56a6edebfc30c3b890b8a990382cf86e543086b148d50bf885478b9553a19a844234560f0029e727f3298e6b6ded02b61e6a55aead9c SHA512 e8fdc953c25a371ea0ecd17e5a94b3215d5e6b60d249d3b91306e50c5ce17c87181f7ada66e75a748e39b3ae773e3da146b29a2929c76e0135a6ad55b3c7b7f3
MISC metadata.xml 405 BLAKE2B e9d6f5ca53505cbfa7f9cd1cdc47bd58ba15ea972bdf342874c031ec151a053025b8f63a8d9c96de90ae0798e77d0db019a70d21e8746449543bfa5d91e3fec0 SHA512 453100976204f0b32042a1711d257ae76214452579d3008f403efc11cdf5e080e3663b43c1946b9da91086de580c0a8cf860fc99c00138c9d1bd4a01a5d1dcc3
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.3.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.3.0.ebuild
new file mode 100644
index 000000000000..cb2e69ec0852
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}