summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
commit34f71cb8541190212fa250ceb3dafb53f383beea (patch)
tree75894a0bd212c9a6464b37d48f418fcb5cc3ff82 /dev-python/django-auth-ldap
parent18bf6672cbde96e8498ce4bfc974af9bb4f95613 (diff)
gentoo auto-resync : 04:04:2024 - 20:14:38
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.8.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index e7db4c65eed8..1e88893f96d0 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,5 +1,7 @@
DIST django-auth-ldap-4.6.0.tar.gz 53845 BLAKE2B 279f7762b858330ab4b63ebb18a8609569ea4d3c7ff1af5ce89d64d8f207445e645d33c9415c4ad289adad0ea2da9674f1ad0d316f63ef42cd6b46c3ac3d7aed SHA512 fc3945fb9cece694b63661c8565d877bdc81e012e9b4e9a8f1840bd83f6effb525e36f40e5dd5018b43d2c7c72fcdd25a5c61bf35e6f0d05e70e830f69228498
DIST django-auth-ldap-4.7.0.tar.gz 53849 BLAKE2B 1c67ba30a0de7e6836fa4e1c0b057001b9b933e252880ae5da44f1ee026f813c0e9115186de3d07071e9e4d76e509b12ca7cdad7968a0ff6ae6f65e6202eb073 SHA512 c31e7e026bb13cba841015db2c7e8fb0d47e3fea968b6257802d03600a23b187e758f5b1891b60fda93a9a39e3c9d1c5b26a03678ed3a4d72c30cb42a2399bf2
+DIST django-auth-ldap-4.8.0.tar.gz 53906 BLAKE2B 76542bfb59c998a681f5e4a4ec0fcae406a672e2fea6b20ef6f59a91987626bec0186d853b789ce0006ace8d0fdbb3b8b2e5855eb84d6d6c93c7040056e4a397 SHA512 4ca16bd5d11680127d2cecfeb7d1d48175e1b9b02e13f84d6845b76a4f52be3ef6c72d5b4bef4418b4f48b441830d3b593fef6cc08a8cd4221c78cfd8464ac8a
EBUILD django-auth-ldap-4.6.0.ebuild 953 BLAKE2B e9286e942280d3fade5e152b54cf395339c27cbeb047d4efb1885c8710544018a6cf75acf25f306256dbe0a920bc7e2f4f25dbdf7e55583a2da257dd61b901a7 SHA512 fc3c7d6c1f675e6f18b0140be4006ce44007d6963fe132dd465f351a64d7db746f5000a123e8ed3f1f4b08cc4825c2e509ba8118852b9431407b92512582ae8e
EBUILD django-auth-ldap-4.7.0.ebuild 953 BLAKE2B e9286e942280d3fade5e152b54cf395339c27cbeb047d4efb1885c8710544018a6cf75acf25f306256dbe0a920bc7e2f4f25dbdf7e55583a2da257dd61b901a7 SHA512 fc3c7d6c1f675e6f18b0140be4006ce44007d6963fe132dd465f351a64d7db746f5000a123e8ed3f1f4b08cc4825c2e509ba8118852b9431407b92512582ae8e
+EBUILD django-auth-ldap-4.8.0.ebuild 953 BLAKE2B e9286e942280d3fade5e152b54cf395339c27cbeb047d4efb1885c8710544018a6cf75acf25f306256dbe0a920bc7e2f4f25dbdf7e55583a2da257dd61b901a7 SHA512 fc3c7d6c1f675e6f18b0140be4006ce44007d6963fe132dd465f351a64d7db746f5000a123e8ed3f1f4b08cc4825c2e509ba8118852b9431407b92512582ae8e
MISC metadata.xml 405 BLAKE2B e9d6f5ca53505cbfa7f9cd1cdc47bd58ba15ea972bdf342874c031ec151a053025b8f63a8d9c96de90ae0798e77d0db019a70d21e8746449543bfa5d91e3fec0 SHA512 453100976204f0b32042a1711d257ae76214452579d3008f403efc11cdf5e080e3663b43c1946b9da91086de580c0a8cf860fc99c00138c9d1bd4a01a5d1dcc3
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.8.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.8.0.ebuild
new file mode 100644
index 000000000000..75c0a161d526
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}