summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
commitf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (patch)
tree6296aa82e3fe61664c80ba6cdd0d7cc410a1c2ad /dev-python/dj-database-url
parent80422eacf48ea819f1aeefc7a809533aa63fb85a (diff)
gentoo auto-resync : 29:03:2023 - 09:53:01
Diffstat (limited to 'dev-python/dj-database-url')
-rw-r--r--dev-python/dj-database-url/Manifest2
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.3.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/Manifest b/dev-python/dj-database-url/Manifest
index 0047d11e609c..3f4034264880 100644
--- a/dev-python/dj-database-url/Manifest
+++ b/dev-python/dj-database-url/Manifest
@@ -1,3 +1,5 @@
DIST dj-database-url-1.2.0.gh.tar.gz 12479 BLAKE2B cc3fed00cd7329a9ee8f3ced5830cf05b7046960ae6397c68b8e67e0609c0284dba01a1736447b45f219290405a0ab4720267feba276b453555e3b8ac2f0d88a SHA512 72b713a3a1ad4c70d857c5c72e671095ef1b7ec8ebd19902296ea49b63b9bf6d0084d03561c8fb47c533da431b44ee17651b45f3f699faceaed0ee6bfe7c921a
+DIST dj-database-url-1.3.0.gh.tar.gz 13215 BLAKE2B 3af4973ce2720166ac6988acc61e02695520fa8bb4f1aad5bd78649959a5f76b2de1aa0822a8c7440fabe130970cf11bdf4c579860660e4e2e0634e594fc2e83 SHA512 f1ff31955e1d1cd39ea8c497ae38b2569f9056d6fa98a5b426472936781153b55b8b1e72475cab50532a753e53f31daafeca7d52de07bca803cfdbef323195b7
EBUILD dj-database-url-1.2.0.ebuild 650 BLAKE2B f6dddf3d82e610f032caea320b19247b3635e1718b7ff3b5c6c42d183817e6ce73d466db36f0bfe3777a180da1bb6b59e76d5b6b2bde1f6779d5d46f5ab649ce SHA512 da18344d9ae694b4abdd37157de15063ce4938e4a228b24c61e720fce3c00152922b5c69699a39f94ec99073eef5be838b8970c71eb043b744c8b9d954603fd3
+EBUILD dj-database-url-1.3.0.ebuild 809 BLAKE2B 4bcfa40804f61e79ab0c1808a6a5be71efb5732df5f4c930bd8364ff7df1b3abbe3ec202578ff48d58b51b9711798056ea7d0709a314ec447779f2da00f01f2c SHA512 66a2707568d7ab5ce391c38983d34476b53d713675ab78bd97c206fa84cb672a74d96cc3f534c5fcd273208c68313e8eb2be0c7b99231123a38440f9784215bf
MISC metadata.xml 407 BLAKE2B 0a3736cc0034297f64b77b9b795e8cd339ed58c5b213e730f1d3dccabe7cde10570222626b2b520bc0e51a0195cd99baf4ebf7028cc73b7e507603874b1f4143 SHA512 ec842e583cd4e0b632731e395f6e70e519077bfeaeb58bb88b9ad297368443fc06a182c120635eeb1dedb76b166829c6f414925d3061e55d49d7053a72c739eb
diff --git a/dev-python/dj-database-url/dj-database-url-1.3.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.3.0.ebuild
new file mode 100644
index 000000000000..7c7f2279f539
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+# tests are missing in sdist as of 1.3.0
+# https://github.com/jazzband/dj-database-url/pull/213
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest