summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /dev-python/dj-database-url
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'dev-python/dj-database-url')
-rw-r--r--dev-python/dj-database-url/Manifest2
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.1.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/Manifest b/dev-python/dj-database-url/Manifest
index 71b30c41102b..f85f04d4ef1e 100644
--- a/dev-python/dj-database-url/Manifest
+++ b/dev-python/dj-database-url/Manifest
@@ -1,3 +1,5 @@
DIST dj-database-url-1.0.0.gh.tar.gz 11355 BLAKE2B 9ea50eb2646367333556133020a59f332cb69e05fb392f328558f77cb03ffa968cf62241f3823e28600799a1399ac1335b90477a26a4931b0df7b695b502e9be SHA512 35ca0c05910812e10bf63b061afb434ac7c562e3d994b6e452250fe4ec95983fe8353aec0df9c7638a990684e612863ddada5be48485a1db3120e110f6d0fa94
+DIST dj-database-url-1.1.0.gh.tar.gz 12095 BLAKE2B 61d32e20ce06451300474f88debb12e960ea6efce8706d6f61991eb204cc8be62f40f38272d9ef177dfa6f4f8a7502c38d17e4c2b01ccb2b256b1dc5329c8dd7 SHA512 4c2ee396daf1a8052a981f8b8df1ba02405020bd4ce3e36df0e34d8be745e5b71a5eb7fef8fc7bff05a8846e9aa1d29857d71e9ba7aa2b5ac0fcb9fabc9f0e60
EBUILD dj-database-url-1.0.0.ebuild 650 BLAKE2B 43251066036bae24f726be99225f4a8a7fea284f539741d5b461d0a2598d37aed207dc64bf47ae206817d1ec05964a6607ca5a3757303a50b14818b8d317bf76 SHA512 f6521432982152f0e6dfeaaa5d7c1e859f713f8d978fbfc8a678353db0327bbb0048dbd9e98dfde689dba91aeb75088f95d20a66b8d2955ca612fc666d56feaa
+EBUILD dj-database-url-1.1.0.ebuild 654 BLAKE2B 0da0bb086aa0c39499f59d81e270b903ad6f997621c30f827a2724fc048726dd4184c1ca57939e1552c92cb740d8e60267920e383d83cd0e3a9de7a9fd268131 SHA512 00757c36e3d74cb94fb98a68867550530da8827a27e0dccec9fa10c3a8e692d7da3838181f7989d9928519a56a5e364eb6344469efa09105c4b082c7a9da3540
MISC metadata.xml 407 BLAKE2B 0a3736cc0034297f64b77b9b795e8cd339ed58c5b213e730f1d3dccabe7cde10570222626b2b520bc0e51a0195cd99baf4ebf7028cc73b7e507603874b1f4143 SHA512 ec842e583cd4e0b632731e395f6e70e519077bfeaeb58bb88b9ad297368443fc06a182c120635eeb1dedb76b166829c6f414925d3061e55d49d7053a72c739eb
diff --git a/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild
new file mode 100644
index 000000000000..c30f6849ca02
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest