summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-0.4.0.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-0.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild b/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
new file mode 100644
index 000000000000..e0e150c7805d
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="https://pypi.python.org/pypi/dj-database-url https://github.com/kennethreitz/dj-database-url"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not contained in the tarball
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" test_dj_database_url.py || die
+}