summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/distlib
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.4-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 1d90844affe4..41ba612f2d02 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,4 +1,5 @@
AUX distlib-0.3.2-system-pypiserver.py 1294 BLAKE2B 87d419e5d9bd90715e43a125617bf12a2eaf16d114557a56fa0c6afb0fa83468960dcfdba3a3eff2ff136c5ef12ec04e71cea2a77a886854181dcdc64aee954e SHA512 08ee2bdc55b30ba770179c97a8dc7f702d72588b6f8bfd65feb47847ee4b41b97c0f31d37e1c4cfc2cff35ccb189abfc07590a175b7d2fd592beda8eb4a8b040
DIST distlib-0.3.4.tar.bz2 1169083 BLAKE2B f1b5e5ca7d0155d204db177d9844cdff4d593be3d927bd5f9e8ad07065b52383527d3990b66c5868bb8377703d031958c5c88a9daf4f0b238903ddbea3ef6cf0 SHA512 24f8d6f5012c881ffa6bbdae7887ee5a7608ac36a83e2a96cb8a337d1ab6c896a4078028d0383165ff44be6b735aa31f7d199845d89899813be74ed00e1680e8
+EBUILD distlib-0.3.4-r1.ebuild 1464 BLAKE2B 9c17b46c711ba6be24ced66902641b5eb7aab63102d4aca63972dcde103e16f19d0a6e1d9b3b0dfae7abb7d23f3401486fbe48cd1ae68e440cc9fdc620b2ca5b SHA512 38dd0d66febc75d8536e516239393841b657f2733c3d27a34671a7f2daf4f2374ca0b2a1c10cba233b1226791474417362684bc50901e7e6c52d440d7b5315ed
EBUILD distlib-0.3.4.ebuild 1452 BLAKE2B 5437e026d18baa362a36ec268f632dc411fc4db3939a63ed33d2e521c11635091df13de403f5681bae8f3f60064e5730c249ba67ed92df75e2f84a45b4e39ee0 SHA512 27ff6601978d34be31ee7f3777af5ec11743cead0dc0617ac9bc3ac4d966c9b6f65fe9e5d37b01c7e5f5fa658e6029ca45d79aa1906bf3c2fe975bd9a11197ae
MISC metadata.xml 289 BLAKE2B 013504330142232b0a1343e0a85d0b29ded52c98dede7dbdd59c7f76dc20f0d0790c34c9cd0f0fca6ac1375bb2895908a9b9be001e1f067f5270241c72d85cc7 SHA512 482e8a6d8f38c56dca30257c1565667370eea4e5dc24ceea2c627566d620d9491ac4ffa4fbf8493d759c9d51064962f77bd74ed904cf58a1d4d3fee30825f9cc
diff --git a/dev-python/distlib/distlib-0.3.4-r1.ebuild b/dev-python/distlib/distlib-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..fced61f71451
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="https://pypi.org/project/distlib/
+ https://bitbucket.org/pypa/distlib/"
+# pypi has zip only :-(
+SRC_URI="
+ https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+# This package's tests are extremely fragile and tend to break or hang
+# when it doesn't like metadata of packages installed on the system.
+RESTRICT="test"
+
+# pypiserver is called as external executable
+# openpyxl installs invalid metadata that breaks distlib
+BDEPEND="
+ test? (
+ dev-python/pypiserver
+ !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ # make sure they're not used
+ rm tests/pypi-server-standalone.py || die
+
+ # use system pypiserver instead of broken bundled one
+ eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
+
+ # doesn't work with our patched pip
+ sed -e '/PIP_AVAIL/s:True:False:' \
+ -i tests/test_wheel.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SKIP_ONLINE=1
+ local -x PYTHONHASHSEED=0
+ "${EPYTHON}" tests/test_all.py -v -x ||
+ die "Tests failed with ${EPYTHON}"
+}