summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 13:00:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 13:00:52 +0100
commite0722f6145f1e8db6281ff135d83442091b31620 (patch)
treee12d701878d995460a24779bd4e1d7689acbeb78 /dev-python/distlib
parentdcb9c4187a31b8b770600503289d2ad39745e782 (diff)
gentoo auto-resync : 18:07:2023 - 13:00:52
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest3
-rw-r--r--dev-python/distlib/distlib-0.3.7.ebuild59
-rw-r--r--dev-python/distlib/files/distlib-0.3.7-pypy3.patch13
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index c77f8d7f049c..3410cb76b7b9 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,5 +1,8 @@
AUX distlib-0.3.2-system-pypiserver.py 1294 BLAKE2B 87d419e5d9bd90715e43a125617bf12a2eaf16d114557a56fa0c6afb0fa83468960dcfdba3a3eff2ff136c5ef12ec04e71cea2a77a886854181dcdc64aee954e SHA512 08ee2bdc55b30ba770179c97a8dc7f702d72588b6f8bfd65feb47847ee4b41b97c0f31d37e1c4cfc2cff35ccb189abfc07590a175b7d2fd592beda8eb4a8b040
AUX distlib-0.3.6-py312.patch 2001 BLAKE2B 761b186ba02ceb3af5a5b88523be120707e1e1be401bdf6b63463e88466250df7f83ac0abd2b22abef15fb8a8420247e265434eeb8d69b18ac1b3e8e2a4aca09 SHA512 92af65078333e9e615f1c045f93bd795d894e85fa390c9d2236febd1ea42e9c960cd8e05c0224a11246907f85a790aae63127e695712dbac0522ee05ebddb486
+AUX distlib-0.3.7-pypy3.patch 626 BLAKE2B 9191d50f2a0e634b570f5cf65c7d1870a926eefa0945ad31f63d5c4d952fe6639a5b641b2f799105dd7ad62f0e8d34af1b799695e150d2cfbc2b780a6f0ee06b SHA512 135ee944a49f5d04022676c866b3766a3feffaf09ea499e33c020ff79e83071ff4f2acf5331623086927934de106a18a9e3f466e2b63272039e8d7a83357d084
DIST distlib-0.3.6.gh.tar.gz 1234082 BLAKE2B 384b736d9fb9e63d1b9a9375caf972ddfccb36c99903928505e684fe09b30190f873cf7b109beb6c32a1e4b1e11a1d9947adea74f9dceef3398fcc1963a2044a SHA512 39948539764ff5d45f14dc602ebd47d523b71b587ee081d7a267669aef4e4b1013d3995cb992038136bc4c01826ea633c6e4ffd050f1511705b296bf76f3bbf9
+DIST distlib-0.3.7.gh.tar.gz 1240451 BLAKE2B 2050133ae1f57a2b37013e0e49a22903a816377d111e6a35c57084e2dd7877b41e9625e3cccbc9e67c35239814b835b064f94eec8bcd41dedd7d329f9d5be2ec SHA512 33806fd953c4b185eaa69c7d0f0cdad9ea71be73d26f0585cefd4a332edbcc3c6287b3bce024858d5d15626311f2567474b19b6366f80b2336d9b39691c6fe31
EBUILD distlib-0.3.6.ebuild 1361 BLAKE2B 744c3b04d88b5fc5b5e1071262dc628481d1e0ea2e793d08023d9b233abc77d7e5ccaed0efc019d65ab631b892143e34ceec78f48e348e1a20f586532cdf1528 SHA512 913932c9a414a6b54f6b8d904b84e9a08b6e72c713d09ed8382109573cfce035b69bde7966a44a9779616c9e690a4bb9ee49fa91b75b287a2fe5c899e6458415
+EBUILD distlib-0.3.7.ebuild 1429 BLAKE2B 07c8aadc3c33d30cb4edbe7e31dd232f42a4c9700217babc9964d36f3746d20bc1a60056b02310226f4e50d1c6f59d5ea16577e0c4de1d3eee79bf509873b49b SHA512 fca2089502b7c63d95a51c41541c7294cb7d1d81e1bad3b67d6a5393c9d841bce75df93dd07cff052e4d454f105bca1e1ccdb401d084c0b7270e106130481898
MISC metadata.xml 365 BLAKE2B 74d46041d58af096a40f55e08c48562eb11aa8349f2a5afeffad67182c65561b71e2723254df6176b77852f74fd569bb329e21bc8f4ba70828dc8fdb361bf518 SHA512 3d5da338be7508640eaff3ac9360387a6b98d40df477b81e9d4dd9b642e84c8d3fbdbf8c277dfaadc869bd733616329b02607fe56357139be4721d4cabb7996a
diff --git a/dev-python/distlib/distlib-0.3.7.ebuild b/dev-python/distlib/distlib-0.3.7.ebuild
new file mode 100644
index 000000000000..8d237a4bfc38
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="
+ https://pypi.org/project/distlib/
+ https://github.com/pypa/distlib
+"
+SRC_URI="
+ https://github.com/pypa/distlib/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pypiserver is called as external executable
+BDEPEND="
+ test? (
+ dev-python/pypiserver
+ )
+"
+
+src_prepare() {
+ local PATCHES=(
+ # use system pypiserver instead of bundled one
+ "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py
+ # fix pypy3
+ # https://github.com/pypa/distlib/issues/204
+ "${FILESDIR}"/${P}-pypy3.patch
+ )
+
+ # make sure they're not used
+ rm tests/pypi-server-standalone.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SKIP_ONLINE=1
+ local -x PYTHONHASHSEED=0
+
+ # disable system-site-packages -- distlib has no deps, and is very
+ # fragile to packages actually installed on the system
+ sed -i -e '/system-site-packages/s:true:false:' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
+
+ "${EPYTHON}" tests/test_all.py -v -x ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/distlib/files/distlib-0.3.7-pypy3.patch b/dev-python/distlib/files/distlib-0.3.7-pypy3.patch
new file mode 100644
index 000000000000..eeb1a924069e
--- /dev/null
+++ b/dev-python/distlib/files/distlib-0.3.7-pypy3.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/test_scripts.py b/tests/test_scripts.py
+index 9ec1d43..2fc18ae 100644
+--- a/tests/test_scripts.py
++++ b/tests/test_scripts.py
+@@ -112,7 +112,7 @@ class ScriptTestCase(DistlibTestCase):
+ bindir = os.path.join(dstdir, 'bin')
+ maker = ScriptMaker(self.maker.source_dir, bindir,
+ add_launchers=False)
+- venv.create(dstdir)
++ venv.create(dstdir, symlinks=True)
+ maker.executable = os.path.join(bindir, 'python')
+ filenames = maker.make('script8.py')
+ p = subprocess.Popen(filenames[0], shell=True,