summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
commit0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (patch)
treefca9d00e42cd967e466d66fd8d23d3bcee39cf75 /dev-python/distlib
parentc3d998909264b1ff687b9c65cae3046443e66f7e (diff)
gentoo auto-resync : 26:08:2022 - 20:52:47
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest2
-rw-r--r--dev-python/distlib/distlib-0.3.6.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 55c1cfe7c51f..69eb0531bc7f 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,4 +1,6 @@
AUX distlib-0.3.2-system-pypiserver.py 1294 BLAKE2B 87d419e5d9bd90715e43a125617bf12a2eaf16d114557a56fa0c6afb0fa83468960dcfdba3a3eff2ff136c5ef12ec04e71cea2a77a886854181dcdc64aee954e SHA512 08ee2bdc55b30ba770179c97a8dc7f702d72588b6f8bfd65feb47847ee4b41b97c0f31d37e1c4cfc2cff35ccb189abfc07590a175b7d2fd592beda8eb4a8b040
DIST distlib-0.3.5.gh.tar.gz 1233989 BLAKE2B 616666e835aa201ceeeb423452a25adafab67dc20f99496b711e3ca6d4916f4e1dd39e444b1c8824e90559e898fc0588cd58d2d5be07af172d6b6ed3f3c7fe4c SHA512 927861d2e11785d8419c3125784f21ee052883c03d91d8893d2c77b47739e45cbca39e5d90446e906c71744bd57274192b28af86def239a16caeae4d3887d5a6
+DIST distlib-0.3.6.gh.tar.gz 1234082 BLAKE2B 384b736d9fb9e63d1b9a9375caf972ddfccb36c99903928505e684fe09b30190f873cf7b109beb6c32a1e4b1e11a1d9947adea74f9dceef3398fcc1963a2044a SHA512 39948539764ff5d45f14dc602ebd47d523b71b587ee081d7a267669aef4e4b1013d3995cb992038136bc4c01826ea633c6e4ffd050f1511705b296bf76f3bbf9
EBUILD distlib-0.3.5.ebuild 1840 BLAKE2B 9ef601fc43aa276283fd7d730f129ef419e5209869121c3ec64fbd5477bdfbcc525406a09f86fc65e0d15425197742090f4bc0dee2125012a4c4ea6ac3ee5035 SHA512 e5b1d1cd3f9b1f9a7be68ba3707eb806c24cd0c56f39c3cc775a1f3da2040c9d288292d43fbcfa92b915b671a594f11ccb462b4a6996b43fa60c7c72b8bb36a6
+EBUILD distlib-0.3.6.ebuild 1848 BLAKE2B ebe2de7511c4610c38d651a9486310fe9d5194f2a797aa8b775cecc8793ea65b696a948e9a143b0249e7e561ca3fc60299ceb8b75bbc83cb94f2a6a54aabe656 SHA512 c729dbb079660c6e7e421e341ff11125f41b79af692f1adaa24cba7d74a24d58f7c622ec3c78f3ea61e85cf10f100e50a60bb1d2797a06f3375f514ad7411ea9
MISC metadata.xml 365 BLAKE2B 74d46041d58af096a40f55e08c48562eb11aa8349f2a5afeffad67182c65561b71e2723254df6176b77852f74fd569bb329e21bc8f4ba70828dc8fdb361bf518 SHA512 3d5da338be7508640eaff3ac9360387a6b98d40df477b81e9d4dd9b642e84c8d3fbdbf8c277dfaadc869bd733616329b02607fe56357139be4721d4cabb7996a
diff --git a/dev-python/distlib/distlib-0.3.6.ebuild b/dev-python/distlib/distlib-0.3.6.ebuild
new file mode 100644
index 000000000000..b9e474a8db74
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="
+ https://pypi.org/project/distlib/
+ https://github.com/pypa/distlib
+"
+SRC_URI="
+ https://github.com/pypa/distlib/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pypiserver is called as external executable
+# openpyxl installs invalid metadata that breaks distlib
+BDEPEND="
+ test? (
+ dev-python/pypiserver
+ !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # make sure they're not used
+ rm tests/pypi-server-standalone.py || die
+
+ # use system pypiserver instead of broken bundled one
+ eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
+
+ # doesn't work with our patched pip
+ sed -i -e '/PIP_AVAIL/s:True:False:' tests/test_wheel.py || die
+
+ # broken with pypy3
+ sed -i -e 's:test_custom_shebang:_&:' tests/test_scripts.py || die
+ # broken with py3.11, doesn't look important
+ sed -i -e 's:test_sequencer_basic:_&:' tests/test_util.py || die
+ # https://bugs.gentoo.org/843839
+ sed -i -e 's:test_interpreter_args:_&:' tests/test_scripts.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SKIP_ONLINE=1
+ local -x PYTHONHASHSEED=0
+
+ # disable system-site-packages -- distlib has no deps, and is very
+ # fragile to packages actually installed on the system
+ sed -i -e '/system-site-packages/s:true:false:' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
+
+ "${EPYTHON}" tests/test_all.py -v -x ||
+ die "Tests failed with ${EPYTHON}"
+}