summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-12 23:32:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-12 23:32:21 +0000
commit05644e4ce4886d97a712fcdca7d4144a7ced4191 (patch)
tree3954657c7c37c0621e63080b0e0530b9e1d8ad50 /dev-python/distlib
parent3bcdaa6f06fae7659c3ac8294503c45e6736a2e1 (diff)
gentoo auto-resync : 12:12:2023 - 23:32:21
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest2
-rw-r--r--dev-python/distlib/distlib-0.3.8.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 4c1a35acd1d8..6979de5cb476 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,5 +1,7 @@
AUX distlib-0.3.2-system-pypiserver.py 1294 BLAKE2B 87d419e5d9bd90715e43a125617bf12a2eaf16d114557a56fa0c6afb0fa83468960dcfdba3a3eff2ff136c5ef12ec04e71cea2a77a886854181dcdc64aee954e SHA512 08ee2bdc55b30ba770179c97a8dc7f702d72588b6f8bfd65feb47847ee4b41b97c0f31d37e1c4cfc2cff35ccb189abfc07590a175b7d2fd592beda8eb4a8b040
AUX distlib-0.3.7-pypy3.patch 626 BLAKE2B 9191d50f2a0e634b570f5cf65c7d1870a926eefa0945ad31f63d5c4d952fe6639a5b641b2f799105dd7ad62f0e8d34af1b799695e150d2cfbc2b780a6f0ee06b SHA512 135ee944a49f5d04022676c866b3766a3feffaf09ea499e33c020ff79e83071ff4f2acf5331623086927934de106a18a9e3f466e2b63272039e8d7a83357d084
DIST distlib-0.3.7.gh.tar.gz 1240451 BLAKE2B 2050133ae1f57a2b37013e0e49a22903a816377d111e6a35c57084e2dd7877b41e9625e3cccbc9e67c35239814b835b064f94eec8bcd41dedd7d329f9d5be2ec SHA512 33806fd953c4b185eaa69c7d0f0cdad9ea71be73d26f0585cefd4a332edbcc3c6287b3bce024858d5d15626311f2567474b19b6366f80b2336d9b39691c6fe31
+DIST distlib-0.3.8.gh.tar.gz 1240659 BLAKE2B 5d14440bd6886a37e80323ea35370f306135f5b15544180b072ed42c6e7b00799dc4b5fe207adb31eee7234d4f291420bd289b5430bbf38ff0468b29af2ca621 SHA512 98dc6459f54783598aad8ee3b8d80c0092a5d08d4272ad212faeef5e30cf9029b718231681f39d26e48588bb676bae7919f1431ddb51eb3917725f99a5c90457
EBUILD distlib-0.3.7.ebuild 1421 BLAKE2B dddbf8c3c7da5683a8113582e918f6a939bf158095d52b39aa255f18158ee780969ca3e5a14f9cbc2526c8ae6c42576ab2be1183433a8826ff429fbcae5521e0 SHA512 643ebe2b36ac93bcdd5c26687fa0a1d616f2c957f9abbce8b95e5953c983ef83cec16da71d29165cd81dad7f691672e35dd981bc8c0c9b6b22b26d00069c34a5
+EBUILD distlib-0.3.8.ebuild 1332 BLAKE2B 77aac22af8f9d6ed86cc64769386b8c62405b7dc39a971cf84287e5d4682cb75211789b6e0a45d1566b4e4664d9e76b54ef87131d39c94f85be483cd40605548 SHA512 620562e964a44da08185581c84289906f780a3ed9b24fae83e1ba09d8e64afb357c97e9ddac8f3011525c715865734dee51e7ddb2800bfa771b2452b61089519
MISC metadata.xml 365 BLAKE2B 74d46041d58af096a40f55e08c48562eb11aa8349f2a5afeffad67182c65561b71e2723254df6176b77852f74fd569bb329e21bc8f4ba70828dc8fdb361bf518 SHA512 3d5da338be7508640eaff3ac9360387a6b98d40df477b81e9d4dd9b642e84c8d3fbdbf8c277dfaadc869bd733616329b02607fe56357139be4721d4cabb7996a
diff --git a/dev-python/distlib/distlib-0.3.8.ebuild b/dev-python/distlib/distlib-0.3.8.ebuild
new file mode 100644
index 000000000000..a7b5c75a3927
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="
+ https://pypi.org/project/distlib/
+ https://github.com/pypa/distlib
+"
+SRC_URI="
+ https://github.com/pypa/distlib/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pypiserver is called as external executable
+BDEPEND="
+ test? (
+ dev-python/pypiserver
+ )
+"
+
+src_prepare() {
+ local PATCHES=(
+ # use system pypiserver instead of bundled one
+ "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py
+ )
+
+ # make sure it's not used
+ rm tests/pypi-server-standalone.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SKIP_ONLINE=1
+ local -x PYTHONHASHSEED=0
+
+ # disable system-site-packages -- distlib has no deps, and is very
+ # fragile to packages actually installed on the system
+ sed -i -e '/system-site-packages/s:true:false:' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
+
+ "${EPYTHON}" tests/test_all.py -v -x ||
+ die "Tests failed with ${EPYTHON}"
+}