summaryrefslogtreecommitdiff
path: root/dev-python/dissononce/dissononce-0.34.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/dissononce/dissononce-0.34.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/dissononce/dissononce-0.34.3.ebuild')
-rw-r--r--dev-python/dissononce/dissononce-0.34.3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/dissononce/dissononce-0.34.3.ebuild b/dev-python/dissononce/dissononce-0.34.3.ebuild
deleted file mode 100644
index ba5c872c5ff7..000000000000
--- a/dev-python/dissononce/dissononce-0.34.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="A python implementation for Noise Protocol Framework"
-HOMEPAGE="https://github.com/tgalal/dissononce"
-SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples test"
-
-# Currently no tests are available,
-# they will be added in future by upstream.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/transitions[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${P}-fix-test-requirements.patch" )
-
-python_test() {
- esetup.py test
-}
-
-src_install() {
- distutils-r1_src_install
-
- use examples && dodoc examples/patterns/*.py
-}