summaryrefslogtreecommitdiff
path: root/dev-python/disqus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/disqus-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/disqus-python')
-rw-r--r--dev-python/disqus-python/Manifest3
-rw-r--r--dev-python/disqus-python/disqus-python-0.4.2.ebuild28
-rw-r--r--dev-python/disqus-python/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/disqus-python/Manifest b/dev-python/disqus-python/Manifest
new file mode 100644
index 000000000000..8492c0be2ce0
--- /dev/null
+++ b/dev-python/disqus-python/Manifest
@@ -0,0 +1,3 @@
+DIST disqus-python-0.4.2.tar.gz 9751 BLAKE2B 976b44585696291b217247ca1a673d3aec3f5b87600270a6216d51b3c22cf3cac0cac79c8f25e5a4c07982bf6a1c387c2fcbf57589fe2c6ac93a628e25106e66 SHA512 ad55c5d95ff9b382a187cfa13b2cc41ec8e90acb6378ebe11a32fc2dc7b125e3e9ebd94d8f24d686f56e87808cda7642d1356c1dfa1e4b7f5d7e1ee9e7875b0a
+EBUILD disqus-python-0.4.2.ebuild 658 BLAKE2B 7f226d27baa39a5be9ee66c20ef1c156699d26b2ec74c11206604ab39c18d31141781f6820544037ba80a941d108259063fc736f12c3d0fbe17e166d899f1155 SHA512 b6941631eba5cf1711bf5709355a105957a0c982113aef3e6e42ec74816e5fa7ec85bc4fd7389a982dc7da7ea103d4afb26ad873f22753e9692826fc60903acd
+MISC metadata.xml 388 BLAKE2B 34d4d3ca0ebea7c37da09d09748f44ac442a959cc014bb966e24122ec6856e1d0dd3460084bb14588d5ca5dffb2300c7e59b78f8688761be8d89e1cc486092e9 SHA512 80dc55c5648da0fab5f055d9f882f7dd06ae4b5300c8c320ce93ddb712cbaf2689dd7fdb5597cb8edc653b056fe29424f3f4788af7cf21a036d5294c64a435e7
diff --git a/dev-python/disqus-python/disqus-python-0.4.2.ebuild b/dev-python/disqus-python/disqus-python-0.4.2.ebuild
new file mode 100644
index 000000000000..457a583e5641
--- /dev/null
+++ b/dev-python/disqus-python/disqus-python-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client library for accessing the disqus.com API"
+HOMEPAGE="https://github.com/disqus/disqus-python"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" "${S}/disqusapi/tests.py" || die
+}
diff --git a/dev-python/disqus-python/metadata.xml b/dev-python/disqus-python/metadata.xml
new file mode 100644
index 000000000000..88317eb4e109
--- /dev/null
+++ b/dev-python/disqus-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">disqus/disqus-python</remote-id>
+ <remote-id type="pypi">disqus-python</remote-id>
+ </upstream>
+</pkgmetadata>