summaryrefslogtreecommitdiff
path: root/dev-python/diskcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/diskcache
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest3
-rw-r--r--dev-python/diskcache/diskcache-2.8.3.ebuild41
-rw-r--r--dev-python/diskcache/metadata.xml12
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
new file mode 100644
index 000000000000..38db73412776
--- /dev/null
+++ b/dev-python/diskcache/Manifest
@@ -0,0 +1,3 @@
+DIST diskcache-2.8.3.tar.gz 438587 BLAKE2B 3b7b50fe6cabe8a4eb92b3dd72a2b99d6cedc8b7d055fcdf7b445f016957e6c7692571e9f83aafe36141b69a0e93f638b9e3e2f210bb56e6358260a5ff4130d3 SHA512 d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d
+EBUILD diskcache-2.8.3.ebuild 835 BLAKE2B 9a5a25f2dd702b75ea4251d43c345675b835b51dc69037590c6f1b13642af450c1bd9366fb8ce072c5c1b91bea87696ee39533fa875942689b140799ffd2dfef SHA512 6a4cf34d327443a155b22951f975bc9dba34d6c2da5cbc2ac6f620088147ad01fd35136051516d6c11aa1b31e8002ab7fe10e24067c16c6b1520e643ac5590ac
+MISC metadata.xml 391 BLAKE2B 74eba8c76944b17dd3b7a446129b9786a56e1afa0a787af75c8e832317b5051afa7e527ac8e7c04a2f9f4c36b0eb3bc72a61655f7de4a5caf9048c50f438d745 SHA512 0d088c14dbbf7c11541b5f47d193280c0f92f8f1b3ec62c8aad49648b3fbcc393ce639b5b9ae18533a4d4b9cb5ad536a5a847b705e2b4bd385d3b90d48f812ec
diff --git a/dev-python/diskcache/diskcache-2.8.3.ebuild b/dev-python/diskcache/diskcache-2.8.3.ebuild
new file mode 100644
index 000000000000..8dba94ae6c0a
--- /dev/null
+++ b/dev-python/diskcache/diskcache-2.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}
diff --git a/dev-python/diskcache/metadata.xml b/dev-python/diskcache/metadata.xml
new file mode 100644
index 000000000000..bda6b340bb5b
--- /dev/null
+++ b/dev-python/diskcache/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">diskcache</remote-id>
+ <remote-id type="github">grantjenks/python-diskcache</remote-id>
+ </upstream>
+</pkgmetadata>