summaryrefslogtreecommitdiff
path: root/dev-python/diskcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
commit7d040c2d1b0c38c8635ec28dfaa632a2db8be895 (patch)
tree78e9474cad949bcd1254749d61f4f6b9e7d488bf /dev-python/diskcache
parent0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (diff)
gentoo auto-resync : 11:04:2023 - 23:39:54
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest2
-rw-r--r--dev-python/diskcache/diskcache-5.5.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 999159f1fb23..b525eb62a828 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,3 +1,5 @@
DIST diskcache-5.4.0.gh.tar.gz 653968 BLAKE2B 765f0d8d9c4b3a8bf9e4c52b3b931867dc0b92aa7b891d6d64cbfe9e7ff491662a1fa2f0af776f9b3dcc4b441f50b68dc009a29e9b0d37f99add9033f4fb94d8 SHA512 cc15ff0b06b2a5708692f50e185699bd53e60408cef25053bcb5aaffec2795dd53c3bfe4b131a47f68c43388927ecc034c43233c38494cb2f6e40636344270fc
+DIST diskcache-5.5.1.gh.tar.gz 654928 BLAKE2B ba042de4d02b8d1556b56efbcbb5b5f0de861e61f7dff33c5b65c6c7bbd362e72a18293bfcd146faf4a83f6ac31443bae5cf4de80910a9cd49f63149ab93b5f4 SHA512 f9cfa8bcabc36bcc0d36c8c6912756abb7eb2f40b8cfb2b49302a2bf7287e52a16885768aafb74a0517777d460ed03a16c8af2465b4c7ae56175a6a7462b5fcd
EBUILD diskcache-5.4.0-r1.ebuild 930 BLAKE2B 7abe674e6186c378049877a291d820c5db40b8b109fead89112316d0638ed8649b28b8fb014550e5e1297e2aa5450397869aa69a4a642155f9161b789491b0c8 SHA512 c133e18a0dc645543e14116abf0f961dc7276b56d21a49d990912abb008c827a911a7c4816d8c58f2eacb02abed399bdbd949ebe270240fa770fb2a61363216e
+EBUILD diskcache-5.5.1.ebuild 971 BLAKE2B ec18f4c5ce08ccc6b75fedb73da2abf4293e4e1bf3082af42b8b0ce155063968f54a84bf4d1ea9608d2e97933e36bda82bd2b0aff4a7b45fd0ec822cd2262d37 SHA512 a9ee0eece4eed3b617b2b0b7979fa47ccb0d0396e8989f13b6c8ffb647c5a320ab6b7a8db53d74e1cfad5f125bfe0e4ac4cff0a19012d86c881e815664075aa5
MISC metadata.xml 417 BLAKE2B ea6f6d25bf863d8be1af817e00d06d668672ddb5cdd938f0bb1a0e92712bdf116540c36014778a160be6ec6144db406f1a1f0d804c3218e38b8bbfc7c1456cc9 SHA512 c5812352980d74ddadbe2192c2c724369ae37d2d0c3d6018220d2ab0bf07559e569af816f3503b8db825a7689cca7a340adc4bd3d1bd73893446a41a7bfb6882
diff --git a/dev-python/diskcache/diskcache-5.5.1.ebuild b/dev-python/diskcache/diskcache-5.5.1.ebuild
new file mode 100644
index 000000000000..cb99ca88f78c
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/
+ https://pypi.org/project/diskcache/
+"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}