summaryrefslogtreecommitdiff
path: root/dev-python/diskcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/diskcache
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest2
-rw-r--r--dev-python/diskcache/diskcache-5.6.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 1df885cc598c..281173907782 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,3 +1,5 @@
DIST diskcache-5.6.1.gh.tar.gz 655959 BLAKE2B 95ba66a8c701796eec1bedcbb514e9288789d52887401f0687374f43c3bd31a502c7e0e0a1fe4b9df05c41a5a1e4efcda8986840749c170295544787e6fd7112 SHA512 a0a6847121089ffe727ec30bd94716d6ab78e5abd4cc8a3230c6ef034b27776be76ca223c3060af3150d2fceadcda670cbf7851c0f47624264342429b29b4f5d
+DIST diskcache-5.6.3.gh.tar.gz 655441 BLAKE2B bc2495862fec7dfffd50e84a7d68e04f42ae8f29c2273466a81e1ec8e82af33a8af3a1f40ac06563c656e48ea24e936402f6269ac498f8521b096e6457aa8df8 SHA512 476d677d88212aa3f9a6e8d12c3e7076cc6a06973d703ed0b2c550b4b4e916b24fb7d8f33c7174854015886fab26e2707b134328d2bc3e144aef5510e7bc0f7c
EBUILD diskcache-5.6.1.ebuild 963 BLAKE2B 1366937fc5d0fc960515f9e175c7b8073d381a6c56cd3abf76494d45dd0f1224f27ea5730d857324b1f7219c8d3854a1d7c08434c9d4c4e9f6e78746fb0727f1 SHA512 055e636db1cfa2df04263e81050b1eb68b0905e505899666c1330d07c98b08e2e83550d0f5555cb531a5807c6be8aee69e39ff872e9e4187f2b6713cad61cb7b
+EBUILD diskcache-5.6.3.ebuild 972 BLAKE2B c1f669d76293409bec4c2400cedc90bd60ea64c2f494aa73345edd97ddd10d6e6e0cb5c026ad10257e39b16fa1a04cc8965603655ff67cad92874d0be423f802 SHA512 b36c08546fe3ff2fc0c53214edb838103f6064f08701107cdf5a614a5d0dd386c0d9710ef73b98170297e9002aeb51e8d76f701a0bc4b0e5a5b56b8919381046
MISC metadata.xml 417 BLAKE2B ea6f6d25bf863d8be1af817e00d06d668672ddb5cdd938f0bb1a0e92712bdf116540c36014778a160be6ec6144db406f1a1f0d804c3218e38b8bbfc7c1456cc9 SHA512 c5812352980d74ddadbe2192c2c724369ae37d2d0c3d6018220d2ab0bf07559e569af816f3503b8db825a7689cca7a340adc4bd3d1bd73893446a41a7bfb6882
diff --git a/dev-python/diskcache/diskcache-5.6.3.ebuild b/dev-python/diskcache/diskcache-5.6.3.ebuild
new file mode 100644
index 000000000000..f99c99d9182d
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/
+ https://pypi.org/project/diskcache/
+"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}