summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/dill
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.2.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 3e91224b717a..9c789ffdd72a 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.1.1.tar.gz 151986 BLAKE2B 71b364730805974117cb00965a2276aa240b6265f2a98ae8e70ca2f9d8bf7a4b801fac083f2395932fdc016de3f068fb46091f296910ce96725bc982e774a40a SHA512 e61610451972522316d7ed6bc8287e38521fcd2e6736b43200ae498f24596994caec92313be1da71cf1b536fbbe01505673fc8018bfcbaf7705147a294565ab9
+DIST dill-0.3.2.gh.tar.gz 148972 BLAKE2B a807350a2d2bb84e705d20c9c60d47834b41863b862a5d347ebc32273c1b9479c568cd3018126adb1cd052bb00f50e8424f7118b37524329458150b9a3e59e3d SHA512 74a0c01dd7c0126c7de21a3b3660e51486fec17f64f23b8e7f23b70243209908573fef8851f6eda53868e89ef1a8a5e351a3ef81dd9cb3e122a2dba33a86bbe1
EBUILD dill-0.3.1.1.ebuild 572 BLAKE2B e6567ad2af1b6b54898b81d0f0cd3bd8e82f6ac176d768252a02a9d7eb9c0069e1df24f91657aef873bb279f51e89c5853eebf428414ea9690b8b5eed9479f66 SHA512 310c104e8b0ebd763d9651f7e43879cdc7ee56bc33bea0ffae024512fb108e9ff08e26ea27e2413c12ba2331f26ed5ce10ed8baab6d4cb2f36665822a99bdbd7
+EBUILD dill-0.3.2.ebuild 633 BLAKE2B a459f682842124d3e1f78ce80b24353e71e4594779b8e86ed6f6cc8a23d00b6ae2071b15dabc078be5db8a8a528cb4006b0740193c51e7aa0cb59b4b6a45afa7 SHA512 1c325c302396875f42cb488267ce4ac3903d8d75b60d155fa99173a5d07f0a7a7a9cdde0724830a6fb4db49fc8d7d6177ab7dd1d36401d8d19a66adc2b6c54e6
MISC metadata.xml 971 BLAKE2B b81903b1c1e32c039f956d6bbbbd8286edc4a80432ae473d6967c16b397aead0df3746d892ed29e94c55d2e555a14e81b068c1a95bef3e87c4248f8809e736d5 SHA512 6dbac6b4684df0f0ca183d998a8c8aaeaa5557d4f20652de04b263a9195b28e56adb7657ab12aebc63715efd2de242b55f3b17648a0337d689756fc4726e5094
diff --git a/dev-python/dill/dill-0.3.2.ebuild b/dev-python/dill/dill-0.3.2.ebuild
new file mode 100644
index 000000000000..32554341e099
--- /dev/null
+++ b/dev-python/dill/dill-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}