summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/dill
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.4-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 3b3b18550a33..3ade8fb5cb14 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,4 @@
DIST dill-0.3.4.gh.tar.gz 152875 BLAKE2B 61c638f0459b94f5cc0dabd9d5fd224c3c010ab6ccc9b7e47943922e7e139bd74c7a5173657febb028fc79632792f807586e271316ad87bb505520163f85a300 SHA512 1b1991909a9782382ecdb2ada13249c8b446d3558de69501280c816f7cd6c6728f9d3303c826461245ab9e42c43c02e4605142f25e09244bb7ccc9ca68a4b565
+EBUILD dill-0.3.4-r1.ebuild 690 BLAKE2B 9788410a39e6bce60f6bb2a637bc10cdcc8dc0d236314f544fa9e83afe404d9e0dc7e0872bbf1f3d7051f73d42877dadb897bfff7ee5030dee596628eff315cf SHA512 9018c38afc8083b64496b97ce7bb5daa72d799f15266b51f693d4d63d3e8d11cc3aa043c3378917c551eb0e28075b36d6681214a06689b6e5c5e5a8aaa6f49a6
EBUILD dill-0.3.4.ebuild 631 BLAKE2B deb8ca8ed00a31b3e0148a1e285948d3bda1eb8288edbf44674c9ba3c7c0394fe6173d229351c2ba2377f9dede1a4ea9194c9163a27fbc649e26447088da0064 SHA512 29894a9f32ad179a8ea45503cdc29ce0644d902d410446f136b2b0cbdac6f76bc429e77bcda37e56995882637017a826909ef988d5114ec0c66fc44b0c1e7eff
MISC metadata.xml 997 BLAKE2B ae32cd96d7a4967a9886d4903e21720459c0a963a675d301c2bb651fdb15877d845100822c1e7a7b6184ccaa666cbb6dc58f939616de9c1c22554670d841bd19 SHA512 e3dc363382bea8ed76343b62377c139ad84011a6b804f64b65d93941a7c192c268c0da273c73d5ec1cece7320b15fa88bf5a2f20a628d8845efddab24f3acc5b
diff --git a/dev-python/dill/dill-0.3.4-r1.ebuild b/dev-python/dill/dill-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..7adc8ad7e0e1
--- /dev/null
+++ b/dev-python/dill/dill-0.3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend ${?} || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}