summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/dill
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.3.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index f0b4ac307842..af654434cc75 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.2.gh.tar.gz 148972 BLAKE2B a807350a2d2bb84e705d20c9c60d47834b41863b862a5d347ebc32273c1b9479c568cd3018126adb1cd052bb00f50e8424f7118b37524329458150b9a3e59e3d SHA512 74a0c01dd7c0126c7de21a3b3660e51486fec17f64f23b8e7f23b70243209908573fef8851f6eda53868e89ef1a8a5e351a3ef81dd9cb3e122a2dba33a86bbe1
+DIST dill-0.3.3.gh.tar.gz 149103 BLAKE2B b08830ad1eb47ceb29c6be6ae88ab38338d9a8a325188bc3890b71c7f393792988da4962819f9b82bf7ad9ebd668c96989ef8c55072a2c82483660c4ec01d072 SHA512 bb514c37902412380d99f38293d5cb9d3d6a6643a34e59e6e889c89d845f9b83e9fa3fa9f0a75218575aa56670f287144f2b00abc8359b5fc6cb450351b43b68
EBUILD dill-0.3.2.ebuild 630 BLAKE2B 433932c4cd4c415f331b17a024314e23a4284b95a296b9f26362e039cc1a5b6e512df4e613be195399f3c35dd09b28da49a0dcb624a0477ec7153992f1eebeb2 SHA512 62c23291eeafc72a38d0d6e90493dc0a910735a2042bc059c3a2478b3d69103139c0754f8291aeb67f8417c261eb9a9243675ffc18dddc1c22789fe9233336d7
+EBUILD dill-0.3.3.ebuild 633 BLAKE2B a459f682842124d3e1f78ce80b24353e71e4594779b8e86ed6f6cc8a23d00b6ae2071b15dabc078be5db8a8a528cb4006b0740193c51e7aa0cb59b4b6a45afa7 SHA512 1c325c302396875f42cb488267ce4ac3903d8d75b60d155fa99173a5d07f0a7a7a9cdde0724830a6fb4db49fc8d7d6177ab7dd1d36401d8d19a66adc2b6c54e6
MISC metadata.xml 996 BLAKE2B b76f67cff65e28c22663f6291652a39fc232369ba747542d0840236971d9857989b179c80a09cd736e2cb504e1db12934a083cb7e38922430dd25844b7fa40a3 SHA512 0dada43b585791564a0351ad160f0d5c11e8821c6fc494d5ea833e48d59b84a10a2c9a99501536d00b5fc03fc55cc51839852363790e1ffe0eed9971021dba40
diff --git a/dev-python/dill/dill-0.3.3.ebuild b/dev-python/dill/dill-0.3.3.ebuild
new file mode 100644
index 000000000000..32554341e099
--- /dev/null
+++ b/dev-python/dill/dill-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}