summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/dill
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.4.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 3cbf433caf1b..3fc362d4cb6d 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.3.gh.tar.gz 149103 BLAKE2B b08830ad1eb47ceb29c6be6ae88ab38338d9a8a325188bc3890b71c7f393792988da4962819f9b82bf7ad9ebd668c96989ef8c55072a2c82483660c4ec01d072 SHA512 bb514c37902412380d99f38293d5cb9d3d6a6643a34e59e6e889c89d845f9b83e9fa3fa9f0a75218575aa56670f287144f2b00abc8359b5fc6cb450351b43b68
+DIST dill-0.3.4.gh.tar.gz 152875 BLAKE2B 61c638f0459b94f5cc0dabd9d5fd224c3c010ab6ccc9b7e47943922e7e139bd74c7a5173657febb028fc79632792f807586e271316ad87bb505520163f85a300 SHA512 1b1991909a9782382ecdb2ada13249c8b446d3558de69501280c816f7cd6c6728f9d3303c826461245ab9e42c43c02e4605142f25e09244bb7ccc9ca68a4b565
EBUILD dill-0.3.3.ebuild 631 BLAKE2B 0429407db79c2037790dff2df36b7dccc234b63f4d78cd0e00a4a75aa869e4bdb4747ef56d76ae6c5acd3ca8ac79b7098de564311e0433e470f363f64a080850 SHA512 f43d66c091971868a2cd6d58aee11d3e6179e79a5a261ee2c04b9f7da1d6f3a50581cfb81dceb8158910b7ebb4ef39ddc046cf6653733e03841b3dedb4501b44
+EBUILD dill-0.3.4.ebuild 634 BLAKE2B f2f920f7cc9b5b9a23a1a9d2dc8d592b7e80f1067cca8400e88b55d035f016382d4f85a53e89825911b47a38aa0eaa6ce6e437bb51662a12072064e9b7002ca1 SHA512 60d94d3984b8a130b6cf28bdb8158bd0a45ee3f7ffe4295e4565fe4413f0d0236c644124320a8cf1602af197a6210266bd8a85211908a980ebaee0e8ab002936
MISC metadata.xml 996 BLAKE2B b76f67cff65e28c22663f6291652a39fc232369ba747542d0840236971d9857989b179c80a09cd736e2cb504e1db12934a083cb7e38922430dd25844b7fa40a3 SHA512 0dada43b585791564a0351ad160f0d5c11e8821c6fc494d5ea833e48d59b84a10a2c9a99501536d00b5fc03fc55cc51839852363790e1ffe0eed9971021dba40
diff --git a/dev-python/dill/dill-0.3.4.ebuild b/dev-python/dill/dill-0.3.4.ebuild
new file mode 100644
index 000000000000..ad2d9fcfa59e
--- /dev/null
+++ b/dev-python/dill/dill-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}