summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
commitbb17db5f98333b3c74b4194d1c1136144f693add (patch)
tree65d7446b00fbeb21e2dd8dc4c106526dd4a8fb7d /dev-python/dill
parent1e9275d80771f014d7754407ca8ab9d7c43247b0 (diff)
gentoo auto-resync : 24:10:2022 - 09:51:42
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.6.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index dc64cd27d983..32b293372096 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.5.1.gh.tar.gz 161203 BLAKE2B 2f778f3d2792d5606f8a5d7fd7d993490592da5ade701a38a270f756d129ad49f2aa44277fcb1f69a14779fe2541e2a720dc643ebd0fad258725d5d9452c048f SHA512 3dcf5e262110031412d9dfaee5548fed80bfc4d6b404cddbc2d9a6f65e2b80fae45a622ef73768e7996d2fc9e8d2757ac04e2a73f3700c526037dbabaa8adf15
+DIST dill-0.3.6.gh.tar.gz 171608 BLAKE2B 3b0c6f20218230685c91c10edb4d9bfdbb913464903ce03c92c85ad607ab3973c61c39f9a9807d55c1d3aa3736f5de4575e5beb0784f2b17f0af850210bebd61 SHA512 921bd5122b9b90fd3426a7af5fc8ba70d09b92d740951f5db5d481abb280915d722410f174ab028134acff9a3659899c8f315242caa7a44d8e4b38dd02bb1fa3
EBUILD dill-0.3.5.1.ebuild 769 BLAKE2B d853fb334f98d1bd785742d196532ce217bfdc24f34151015a8f4604fc54f8a455c407e37525be79ea147b7484d558d432d9a2165a2874a1f1aa4b6005b3d083 SHA512 1d88ac63f5d83e33ae72292bf4f651414ece386a9a9c608cfeb9a67bb3394f9f2b24f16d00ef68e97c182112ad2ef8111d4dca06aaf70b7e6d90e6b40e17d5a5
+EBUILD dill-0.3.6.ebuild 647 BLAKE2B b46ea094b388feed2d4a894787cc9754c0688373b16322a1c97f1cc705721b3b41c64dec301e7ffbb857f5fb059d447b83844e4d48d684f753612c2b61b09b55 SHA512 35fac7a1e75b2531f9c3a95e5eff625ee141dc71b1354df09fbe257e9d5ed5ab8943dfe501063a54e4b4d3b3402f7b6532a4845fd2d3ce0c88d5b209bc3ab5af
MISC metadata.xml 997 BLAKE2B ae32cd96d7a4967a9886d4903e21720459c0a963a675d301c2bb651fdb15877d845100822c1e7a7b6184ccaa666cbb6dc58f939616de9c1c22554670d841bd19 SHA512 e3dc363382bea8ed76343b62377c139ad84011a6b804f64b65d93941a7c192c268c0da273c73d5ec1cece7320b15fa88bf5a2f20a628d8845efddab24f3acc5b
diff --git a/dev-python/dill/dill-0.3.6.ebuild b/dev-python/dill/dill-0.3.6.ebuild
new file mode 100644
index 000000000000..1f68f4b57d03
--- /dev/null
+++ b/dev-python/dill/dill-0.3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" -m dill.tests || die
+}