summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dill
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest5
-rw-r--r--dev-python/dill/dill-0.2.5.ebuild22
-rw-r--r--dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch29
-rw-r--r--dev-python/dill/files/dill-0.2.5-remove-install_requires.patch28
-rw-r--r--dev-python/dill/metadata.xml22
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
new file mode 100644
index 000000000000..b9962f181815
--- /dev/null
+++ b/dev-python/dill/Manifest
@@ -0,0 +1,5 @@
+AUX dill-0.2.5-avoid-installation-binaries.patch 784 BLAKE2B 74f3c8ac45a1ab97dbbcff9965c7acc0357bd8253cdaf317ccfe54294c35ef08cf328a3be0586b123365811b56546a2190eda4d76702efe7f8e5289333de093a SHA512 cb944c7e4699a99a5040140f2dd1cf6bbe3148b0fe098c536200cddd4ed835545c7e8328072a188fc9a5d70b9b4f5d3a138108f934734ee9c8021b3e95126cc4
+AUX dill-0.2.5-remove-install_requires.patch 906 BLAKE2B b8d38d701448930cf8596be8ccc3fd81f85e4f72dc2a6b64c3003ba3a21f86d41dd16ffda86c89e2e2f2714a96d6b92ebd19d05a40676e01efcf656fefcdae42 SHA512 f984248a8280a1cf97bca6a8ad90f8d648da106a74c67dfe29f62e5d8591d7cfcb608bf827729430f0463f6ad0846dba094a030b5c2c3e3f8f387f39803f737e
+DIST dill-0.2.5.tgz 60572 BLAKE2B 43877e36cb62406b486f5619a54db0a4983f70b0a1712e39bcd77aa892fd17dc9ea774b85faa48441beaf993296a877249ff321fd0977a1317eeb25d0b020d80 SHA512 94942a736b4c2e1558eb9475f9bafe3a24f88a976abf9880beec386497a2bc769cb9be6bbfd2baac006c92578c372f5dfcfa165c5649876ea5076a3b207de6fc
+EBUILD dill-0.2.5.ebuild 533 BLAKE2B b180ee84c400e106a040039712c9026909dbd7e2c7ea3664e4e3935f494bc07c3a21ea98558d78af2d8be2e9682a87ddc60b26b4e5b4238ec5c251bea71e7d97 SHA512 6ee9e899716f475d740896bf4b5d702b8a0871a503191966038d2d234c88c957c5a61d7a29f35243e10219818de5caabe1d0bee2ce73294ce81657b329fc6a1a
+MISC metadata.xml 971 BLAKE2B b81903b1c1e32c039f956d6bbbbd8286edc4a80432ae473d6967c16b397aead0df3746d892ed29e94c55d2e555a14e81b068c1a95bef3e87c4248f8809e736d5 SHA512 6dbac6b4684df0f0ca183d998a8c8aaeaa5557d4f20652de04b263a9195b28e56adb7657ab12aebc63715efd2de242b55f3b17648a0337d689756fc4726e5094
diff --git a/dev-python/dill/dill-0.2.5.ebuild b/dev-python/dill/dill-0.2.5.ebuild
new file mode 100644
index 000000000000..954cd7b836d7
--- /dev/null
+++ b/dev-python/dill/dill-0.2.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-avoid-installation-binaries.patch"
+ "${FILESDIR}/${P}-remove-install_requires.patch"
+)
diff --git a/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
new file mode 100644
index 000000000000..16525c10b343
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
@@ -0,0 +1,29 @@
+From dfa34a34f09d0f868cc404d5c1ccf071f47fe63f Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:07:04 -0600
+Subject: Patch to avoid the installation of upstream binaries under the wrong
+ directories
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8f91183..1ee6dcf 100644
+--- a/setup.py
++++ b/setup.py
+@@ -283,10 +283,10 @@ if has_setuptools:
+ """ % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+-setup_code += """
+- scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
+-"""
+-
++#setup_code += """
++# scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
++#"""
++setup_code += ")"
+ # exec the 'setup' code
+ exec(setup_code)
+
diff --git a/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
new file mode 100644
index 000000000000..dfa5f0dd653d
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
@@ -0,0 +1,28 @@
+From 9b32a0be077d5295a42fec7cb17810fa3e8aca45 Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:11:04 -0600
+Subject: Removes install_requires in order to avoid automatic package
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 1ee6dcf..dd90af5 100644
+--- a/setup.py
++++ b/setup.py
+@@ -277,10 +277,10 @@ if has_setuptools:
+ install_requires = ['pyreadline%s'],
+ """ % (pyreadline_version)
+ # verrrry unlikely that this is still relevant
+- elif hex(sys.hexversion) < '0x20500f0':
+- setup_code += """
+- install_requires = ['ctypes%s'],
+-""" % (ctypes_version)
++# elif hex(sys.hexversion) < '0x20500f0':
++# setup_code += """
++# install_requires = ['ctypes%s'],
++#""" % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+ #setup_code += """
diff --git a/dev-python/dill/metadata.xml b/dev-python/dill/metadata.xml
new file mode 100644
index 000000000000..b277396800f0
--- /dev/null
+++ b/dev-python/dill/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dill extends Python's 'pickle' module for serializing and de-serializing Python
+ objects to the majority of the built-in Python types.
+ Dill provides the user the same interface as the 'pickle' module, and also
+ includes some additional features. In addition to pickling Python objects,
+ dill provides the ability to save the state of an interpreter session in a
+ single command.
+ Dill can be used to store Python objects to a file, but the primary usage is to
+ send Python objects across the network as a byte stream.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dill</remote-id>
+ <remote-id type="github">uqfoundation/dill</remote-id>
+ </upstream>
+</pkgmetadata>