summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dill
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest6
-rw-r--r--dev-python/dill/dill-0.2.5.ebuild22
-rw-r--r--dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch29
-rw-r--r--dev-python/dill/files/dill-0.2.5-remove-install_requires.patch28
-rw-r--r--dev-python/dill/metadata.xml22
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
new file mode 100644
index 000000000000..56266e7d9f09
--- /dev/null
+++ b/dev-python/dill/Manifest
@@ -0,0 +1,6 @@
+AUX dill-0.2.5-avoid-installation-binaries.patch 784 SHA256 94a022411360c089d0a6fe1bc7fc8b9680a8428399f6cedef3e1cd206dda490b SHA512 cb944c7e4699a99a5040140f2dd1cf6bbe3148b0fe098c536200cddd4ed835545c7e8328072a188fc9a5d70b9b4f5d3a138108f934734ee9c8021b3e95126cc4 WHIRLPOOL c1065f9fb6393268eabf7c1c31ede92c7037c916a58213c39fbc2bdc4e8cc963b66c7c2cc874bef92c903c61a74215af46f5f9f483abb46452801b9f09f3cc1d
+AUX dill-0.2.5-remove-install_requires.patch 906 SHA256 5e87b1f2e89303e346e67c9489e5f1efbf8b80462391ca3878ea8269cbaa14ac SHA512 f984248a8280a1cf97bca6a8ad90f8d648da106a74c67dfe29f62e5d8591d7cfcb608bf827729430f0463f6ad0846dba094a030b5c2c3e3f8f387f39803f737e WHIRLPOOL 706b9669111e6d97051308f34cfaf91c1f877f1aad19836cce20e688fde030e24808af8ee7d2b763432817f4c1b49e2d6b36c8bea8b13b08917ab98877a15f7c
+DIST dill-0.2.5.tgz 60572 SHA256 431c9d46e190dcdf1397234cf659d66e2e22e33b0474ed6ee2d0b16c9c0ea319 SHA512 94942a736b4c2e1558eb9475f9bafe3a24f88a976abf9880beec386497a2bc769cb9be6bbfd2baac006c92578c372f5dfcfa165c5649876ea5076a3b207de6fc WHIRLPOOL b0af3e279ad937f36450f25711412b7e48928515e4721fee3d91663c4ec629357b6d8f3c661f1ac56d3f7343a3bef717a368386bd8983991e06a4ce0f78ae1f9
+EBUILD dill-0.2.5.ebuild 539 SHA256 08884a5f43da4ab13551eb9cd9dfe773890941d9ae064b051acb7547bf1b1915 SHA512 9c8527158c526a1f451d3c54382d735fdd49174abec661b62de6f1efe82c6b2322a692b56b52e7db14d7ed724a56472a08891fd88d4f8dc6d44729de39963508 WHIRLPOOL eb68466b364e8adcb15b097dd34175b6892bb81ffa86ebb3d0cfe8dba831e3a3397ac70fd1a8a2867c6cc1c54258845d02310e53e6b91191dcf31d22a90905fd
+MISC ChangeLog 584 SHA256 67faf3c55103290e2a9646ed06fdf87aa9bbb616421a15627b5fcf2fd9a282b0 SHA512 d61e9723a0bd2d1f30e9c3a9a08827da42938383a7db53e203fa0f33d78deab4130947d85687eff64ac42dd1a2558f7e0a0b78db31bb6416f4feb5534d27425d WHIRLPOOL 34aff99293e2d0089f48b56ec8197667d07e858a355ac0e6ec8f8fdde61d54cb197c479ac49b493c2ce8911e6cc0f3d9d645953abd7ad6f150d0e106b3bc13a3
+MISC metadata.xml 971 SHA256 ab1e928df07d5cb6379870e89c5c7543a42f132d0dd066a04f4a3794f82942c2 SHA512 6dbac6b4684df0f0ca183d998a8c8aaeaa5557d4f20652de04b263a9195b28e56adb7657ab12aebc63715efd2de242b55f3b17648a0337d689756fc4726e5094 WHIRLPOOL bb511abf04b29ac539657380fe2ae17d80fcda8a5e3e42ce074ad90970a18d00c5d8c3e0d051e601ddbab82796490a7a9647e4f2c1cc95f29f405f0e7c6e3a6b
diff --git a/dev-python/dill/dill-0.2.5.ebuild b/dev-python/dill/dill-0.2.5.ebuild
new file mode 100644
index 000000000000..d13dba401c3d
--- /dev/null
+++ b/dev-python/dill/dill-0.2.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.python.org/pypi/dill"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-avoid-installation-binaries.patch"
+ "${FILESDIR}/${P}-remove-install_requires.patch"
+)
diff --git a/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
new file mode 100644
index 000000000000..16525c10b343
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-avoid-installation-binaries.patch
@@ -0,0 +1,29 @@
+From dfa34a34f09d0f868cc404d5c1ccf071f47fe63f Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:07:04 -0600
+Subject: Patch to avoid the installation of upstream binaries under the wrong
+ directories
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8f91183..1ee6dcf 100644
+--- a/setup.py
++++ b/setup.py
+@@ -283,10 +283,10 @@ if has_setuptools:
+ """ % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+-setup_code += """
+- scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
+-"""
+-
++#setup_code += """
++# scripts=['scripts/unpickle.py','scripts/get_objgraph.py'])
++#"""
++setup_code += ")"
+ # exec the 'setup' code
+ exec(setup_code)
+
diff --git a/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
new file mode 100644
index 000000000000..dfa5f0dd653d
--- /dev/null
+++ b/dev-python/dill/files/dill-0.2.5-remove-install_requires.patch
@@ -0,0 +1,28 @@
+From 9b32a0be077d5295a42fec7cb17810fa3e8aca45 Mon Sep 17 00:00:00 2001
+From: Josue Ortega <josueortega@debian.org.gt>
+Date: Sun, 1 Nov 2015 13:11:04 -0600
+Subject: Removes install_requires in order to avoid automatic package
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 1ee6dcf..dd90af5 100644
+--- a/setup.py
++++ b/setup.py
+@@ -277,10 +277,10 @@ if has_setuptools:
+ install_requires = ['pyreadline%s'],
+ """ % (pyreadline_version)
+ # verrrry unlikely that this is still relevant
+- elif hex(sys.hexversion) < '0x20500f0':
+- setup_code += """
+- install_requires = ['ctypes%s'],
+-""" % (ctypes_version)
++# elif hex(sys.hexversion) < '0x20500f0':
++# setup_code += """
++# install_requires = ['ctypes%s'],
++#""" % (ctypes_version)
+
+ # add the scripts, and close 'setup' call
+ #setup_code += """
diff --git a/dev-python/dill/metadata.xml b/dev-python/dill/metadata.xml
new file mode 100644
index 000000000000..b277396800f0
--- /dev/null
+++ b/dev-python/dill/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dill extends Python's 'pickle' module for serializing and de-serializing Python
+ objects to the majority of the built-in Python types.
+ Dill provides the user the same interface as the 'pickle' module, and also
+ includes some additional features. In addition to pickling Python objects,
+ dill provides the ability to save the state of an interpreter session in a
+ single command.
+ Dill can be used to store Python objects to a file, but the primary usage is to
+ send Python objects across the network as a byte stream.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dill</remote-id>
+ <remote-id type="github">uqfoundation/dill</remote-id>
+ </upstream>
+</pkgmetadata>