summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-28 06:57:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-28 06:57:12 +0000
commit3afceb132f6ff416c4f715f21857dacb9c605bc8 (patch)
tree6d5fd8da5f1ddb80d670334d15492be7cdeb7dcf /dev-python/dill
parent2865ab43f3d9f17ce41a2b048f7ca1ea32177955 (diff)
gentoo auto-resync : 28:01:2024 - 06:57:12
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.8.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index c18d8cd2bf4f..a01013a31a60 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.7.gh.tar.gz 176315 BLAKE2B 8c98c40458035e42c078c79df14e474c35a2a6ff4f61d3cfca8f4dfa5a7756512b7d5af6276becd88315c01d88c8562de02b6f9dff06d0161df3e6f6694c7cc8 SHA512 33ec55dc32c9ddf275ce6e502187949bbc7ecc6d24560e132a7bed23e93254b771d38e59c4b6313bbfc25313305c43c6cba2fe07763a93238e1ba66c4bbd8cd4
+DIST dill-0.3.8.tar.gz 184847 BLAKE2B 6a0eb76526d5bc4afa003f34454c3a93b2b53e2d5bd362749bfcc22c6fe294dff3af9d52e83b288e999d7074d82a2671b3d271b3b423030f4cfd57cd70acdc6f SHA512 478d83af69dc0639a08e011e46127d9485dc998df54622e7fbb9ce4b004640d1b23aad57717d791cc609cd9d7071ea7300bce4be982488e4d21c5986e67ce586
EBUILD dill-0.3.7.ebuild 653 BLAKE2B b946386d627dd4834ee6b9c812c76069ac3778080261a59cdbe510f0bd92817c8f9f6ed991b6fdcfe473984e773e3467eec77af7151ebbcd481ebb65dfe97b66 SHA512 c7b346c964f1479b9a63ae3b44a042bab04a012c0ca1175d4644ee0a978dc2601cb55077ecee64cf8a852d991830d3c4d36a425451c5a02cadf24beebcc01539
+EBUILD dill-0.3.8.ebuild 552 BLAKE2B 349fade4c654db44c7ea33bc04d9f16db2c15f8b4b4858b136d0194dffc63188327314dce135f732d937c9f0c7c599776cbd70711b1169dea05885554f412602 SHA512 b13002e948cef9998d07963ff83db9fbe9ea66c15fcc4bc12500cab41ac05e3b2bf58d11d02727b6ecf4556a46f59dfda9bac5ab8a2c4a93f91b32d0004b72c7
MISC metadata.xml 997 BLAKE2B ae32cd96d7a4967a9886d4903e21720459c0a963a675d301c2bb651fdb15877d845100822c1e7a7b6184ccaa666cbb6dc58f939616de9c1c22554670d841bd19 SHA512 e3dc363382bea8ed76343b62377c139ad84011a6b804f64b65d93941a7c192c268c0da273c73d5ec1cece7320b15fa88bf5a2f20a628d8845efddab24f3acc5b
diff --git a/dev-python/dill/dill-0.3.8.ebuild b/dev-python/dill/dill-0.3.8.ebuild
new file mode 100644
index 000000000000..5d585d0d1e63
--- /dev/null
+++ b/dev-python/dill/dill-0.3.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" -m dill.tests || die
+}