summaryrefslogtreecommitdiff
path: root/dev-python/diff-match-patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 11:19:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 11:19:44 +0100
commitc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (patch)
tree354e4022d98ceadbdf02f98879cc8b1feb4d61b1 /dev-python/diff-match-patch
parent149480f9f5548b5a0fdb457abd473f8d10f60f51 (diff)
gentoo auto-resync : 01:05:2023 - 11:19:44
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/Manifest4
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20230430.ebuild22
-rw-r--r--dev-python/diff-match-patch/metadata.xml1
3 files changed, 26 insertions, 1 deletions
diff --git a/dev-python/diff-match-patch/Manifest b/dev-python/diff-match-patch/Manifest
index 38b893f2d7e3..9cb027be01bc 100644
--- a/dev-python/diff-match-patch/Manifest
+++ b/dev-python/diff-match-patch/Manifest
@@ -1,3 +1,5 @@
DIST diff-match-patch-20200713.tar.gz 60711 BLAKE2B 9108557050d0aced61e8073e0bfa1969e780e4350dba86e3cb159760d180b09ff2502e8b0a664370e0586bb0ca280f29cfebb983cddf051f10204e3cd1026d8f SHA512 f161efed3d87dd0693c98ee81aedb3868787f040f8f9f31015f9f1de04d50046be75b2351a65a4c26ae1d194b983dbc1420799cf70e7c25737ee4eb3cc78a183
+DIST diff-match-patch-20230430.tar.gz 43324 BLAKE2B c13beb380d68cf96af41c124eb23f890c71664624de20780ea586f71b4c52a55ee06ac3427c61c233ebead309fcca02cb75f3447f17b7306c2728ebc5b06f6f8 SHA512 a62d15327de659999e3381215249fb088a9e40368008b91201de3db3d02f22892bbf6d2ac40dc4ea4986d24470dd396eaf69583fabbe9078a5cb1f97bae94000
EBUILD diff-match-patch-20200713.ebuild 400 BLAKE2B f820250f4daf9469f7455e1c3afb7205a7bc00825902eb05590845b45f3186e88f9e278b8607edb15cba53fdafd6e4778ef65c0abf9d8efef04b4fb8a77aa07f SHA512 b0b5596798ef46246f7609613b912a14d4537380e2c7f60892736453755fd3ee2f3155192acda6e3c3b29e19a3a158a12974721a378f16dc5c8a04c85d7271b4
-MISC metadata.xml 1185 BLAKE2B f7be2dd5be0415434a378ab66383e4ea09bad3e6c4f4d90dd5aa06d00a0ccbcaec735489a2eaa9accb25a95203a7328895c76b98a15097971b921b9842548ed9 SHA512 c11a0ee2ec7ffeb30eb47050baeec4ac87681d31b2469446b9eca9387c278c716fcbd66e3d8807ba4ab6f070f26f02d0d6af87fb3857fd7df7ceb9da329cc851
+EBUILD diff-match-patch-20230430.ebuild 494 BLAKE2B 9208f851b244291aac99dd5472550275ecd553d30e5fab887bea53d367fce4535837b1dd7621398314aa9563a84baacd0adebbe9ee026b4ee921efdc3a84ecbc SHA512 a89fce45b8df1a698087a71e63df6ef0f370a83414ffd73dbda8906ee8959c5b5885a0fecb35717ace444f4c9207300ca8818cbb253720e026f84667dd729c22
+MISC metadata.xml 1265 BLAKE2B b9cee200ca7d1e918e77f065231d8860293ce280f6b66451609632d777d09f9b241119952805151120a361cc6f09eadac8c3cefe45cd66ae38f807dcff0641cd SHA512 0ccfcac32e5a2f4a3604cf2b97fae2e6a98fdf0b8a426c6c05c1f9818652a9ca4583e4bc4e7c6ba72d7c72b2fc397fbd3863e9f0a65da9f60c4373e4c087ad05
diff --git a/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild b/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild
new file mode 100644
index 000000000000..0251b27bf244
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="
+ https://github.com/diff-match-patch-python/diff-match-patch/
+ https://pypi.org/project/diff-match-patch/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/diff-match-patch/metadata.xml b/dev-python/diff-match-patch/metadata.xml
index 8ff39d9ab20a..3a1754d7588c 100644
--- a/dev-python/diff-match-patch/metadata.xml
+++ b/dev-python/diff-match-patch/metadata.xml
@@ -20,6 +20,7 @@
library features the same API and the same functionality. All versions
also have comprehensive test harnesses.</longdescription>
<upstream>
+ <remote-id type="github">diff-match-patch-python/diff-match-patch</remote-id>
<remote-id type="pypi">diff-match-patch</remote-id>
</upstream>
</pkgmetadata>