summaryrefslogtreecommitdiff
path: root/dev-python/diff-match-patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/diff-match-patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/Manifest3
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20121119.ebuild24
-rw-r--r--dev-python/diff-match-patch/metadata.xml28
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/Manifest b/dev-python/diff-match-patch/Manifest
new file mode 100644
index 000000000000..ee697b8a4015
--- /dev/null
+++ b/dev-python/diff-match-patch/Manifest
@@ -0,0 +1,3 @@
+DIST diff-match-patch-20121119.tar.gz 54113 BLAKE2B 0fcfa46f02f92af0e31ded7c51c651574104fb4d7d70082873981138579b12231dea0eee417614981a96f7ceaa50b288fefdbc21dca687451095dcdc34fe32f8 SHA512 3daff80a6043a0413c515125a21839d9fa1d71f7e2441f4870ebefed35f1accea711814ad231c65de0e3468bbd01402c977fc063ab120b7d9f0e04ef555a8207
+EBUILD diff-match-patch-20121119.ebuild 519 BLAKE2B 6878ddde9cd7cb7fed9c43a375ba3c85d98d4c0d2e3751970fb7f7c06c1ff853ec23b48861c6a83beda3d4ee1e2a7fe4e6b1c010dd3dea76d869804927228cec SHA512 eee8acf5b7137d21593f4f2369ec7939de93bdf0650739116a57bf8d9272285ee0c09ab5a6d87f547c32f5c0e1500b8041e96680174466d5c1869b6e4e868ea8
+MISC metadata.xml 1275 BLAKE2B b1014d31b63cb9b926bd12d49bf17dd9f204ed5e72522a98926e4c15fd69ced3e826cde8ef86766af00c8d85aa0294b0839b9bed84a9e55c50cd9f2a46f9f55b SHA512 0a5e72080b845fe7ba9b0fb41b51aab1bdc9eb11e702027c9dc1a83c245e54c9b1c667f4e5726a026df75996bdf0ffacf6d3f68ea79705847f657f1b859ee556
diff --git a/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
new file mode 100644
index 000000000000..eacebb921745
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="https://pypi.org/project/diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/diff-match-patch/metadata.xml b/dev-python/diff-match-patch/metadata.xml
new file mode 100644
index 000000000000..85b6549c5455
--- /dev/null
+++ b/dev-python/diff-match-patch/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">The Diff Match and Patch libraries offer robust algorithms to perform
+ the operations required for synchronizing plain text.
+ Diff: Compare two blocks of plain text and efficiently return a list of
+ differences.
+ Match: Given a search string, find its best fuzzy match in a block of
+ plain text. Weighted for both accuracy and location.
+ Patch: Apply a list of patches onto plain text. Use best-effort to apply
+ patch even when the underlying text doesn't match.
+ Diff Match and Patch libraries are currently available in Java,
+ JavaScript, C++, C#, Objective C, Lua and Python, although this package
+ contains only Python implementation. Regardless of language, each
+ library features the same API and the same functionality. All versions
+ also have comprehensive test harnesses.</longdescription>
+ <upstream>
+ <remote-id type="pypi">diff-match-patch</remote-id>
+ </upstream>
+</pkgmetadata>