summaryrefslogtreecommitdiff
path: root/dev-python/diff-match-patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/diff-match-patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/Manifest5
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20121119.ebuild24
-rw-r--r--dev-python/diff-match-patch/metadata.xml28
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/Manifest b/dev-python/diff-match-patch/Manifest
new file mode 100644
index 000000000000..6bcf19e1f1fd
--- /dev/null
+++ b/dev-python/diff-match-patch/Manifest
@@ -0,0 +1,5 @@
+DIST diff-match-patch-20121119.tar.gz 54113 SHA256 9dba5611fbf27893347349fd51cc1911cb403682a7163373adacc565d11e2e4c SHA512 3daff80a6043a0413c515125a21839d9fa1d71f7e2441f4870ebefed35f1accea711814ad231c65de0e3468bbd01402c977fc063ab120b7d9f0e04ef555a8207 WHIRLPOOL ebd50cd7b86cb6c5b003f09d3c8efccda14cb1b2d158123b424f0c2bd40b37338ac8f13dcf464feb408d661db0ed6134fa9fc5c9954ebf35a3ebce206552b3aa
+EBUILD diff-match-patch-20121119.ebuild 523 SHA256 3b1ccf815a0104927a2c7dd6b6826fdfc70dc47ad3f6e44b24c628d006a5dbb3 SHA512 b5eff55fbf006d0da4e78b687d9ebb00922a901a0a3437850c0ec8717d59182e1dc57b7cb652493cf3c8cd20bc2079b1c16729679c997e7d15f2c5a610eb4b49 WHIRLPOOL fc441f898b566172c31e3ec8dc80a32e27d75502737096648f8da3f78555bd09dd8348ada3b4a24a327bd4621c41b55332f1a0c5e54e81cc468b7a35fec2ccb9
+MISC ChangeLog 3222 SHA256 2ec3e836b7b481a8a1ffe858b2a395e589e25134cb284f5a737ec443afb989eb SHA512 af25bce478b5e81446c82d053885ccd1329968b2fce4dac74c9b0ef9a181ee7cbe127a9355b8d1ddbb0164a452ef4641364febd967b78825de79f7977e1f509c WHIRLPOOL 1e09ce1fef9c85a8d8988fe7de477a3e78864abb3ece6b089ba13d954c5f3e8bd02648cc86afa3b11187f89d1cbc795ef8b0ad31669177d7061ab7be068c06b0
+MISC ChangeLog-2015 3062 SHA256 c49579374a6b32511d6feb7edf534a1591498803e3918fd7e1cd22a1c39c3fb6 SHA512 514566c1c79c0aeeade2997e318550d4ddc7375cb87c55346a5d5d371fb0c75e24969648b976036b979779a889a00554561c11f7603ea70e3c0b6dfee7fa5d8d WHIRLPOOL c0a9ceebe34b13b787e208c6da434911ce57a3758b391f76fc8a866a6eee3e8bccdd1e9d56634976f9539faada7934e12b4227d3e4b5f4e177e9c3a5083ba0a6
+MISC metadata.xml 1275 SHA256 3fe90cfbb424ecf6ade75bb6e3c59ecc38d7f73e092b62950b67dc0d9eb86668 SHA512 0a5e72080b845fe7ba9b0fb41b51aab1bdc9eb11e702027c9dc1a83c245e54c9b1c667f4e5726a026df75996bdf0ffacf6d3f68ea79705847f657f1b859ee556 WHIRLPOOL 531db020b6155bdd2ec10e4b58b73711eb7b64e57754bde9da3dd8ee3b3e5710c703a0b9898dd6e49b93d6873315c2fa6e78c664fe9b06d336789575a243565f
diff --git a/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
new file mode 100644
index 000000000000..a0de8651a743
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="https://pypi.python.org/pypi/diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/diff-match-patch/metadata.xml b/dev-python/diff-match-patch/metadata.xml
new file mode 100644
index 000000000000..85b6549c5455
--- /dev/null
+++ b/dev-python/diff-match-patch/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">The Diff Match and Patch libraries offer robust algorithms to perform
+ the operations required for synchronizing plain text.
+ Diff: Compare two blocks of plain text and efficiently return a list of
+ differences.
+ Match: Given a search string, find its best fuzzy match in a block of
+ plain text. Weighted for both accuracy and location.
+ Patch: Apply a list of patches onto plain text. Use best-effort to apply
+ patch even when the underlying text doesn't match.
+ Diff Match and Patch libraries are currently available in Java,
+ JavaScript, C++, C#, Objective C, Lua and Python, although this package
+ contains only Python implementation. Regardless of language, each
+ library features the same API and the same functionality. All versions
+ also have comprehensive test harnesses.</longdescription>
+ <upstream>
+ <remote-id type="pypi">diff-match-patch</remote-id>
+ </upstream>
+</pkgmetadata>