summaryrefslogtreecommitdiff
path: root/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild')
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a6882bd19034
--- /dev/null
+++ b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
+HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ # https://github.com/quandyfactory/dicttoxml/pull/73/files
+ "${FILESDIR}/${P}-py3.10.patch"
+)