summaryrefslogtreecommitdiff
path: root/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-python/dictdiffer/dictdiffer-0.9.0.ebuild')
-rw-r--r--dev-python/dictdiffer/dictdiffer-0.9.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild b/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
new file mode 100644
index 000000000000..7cee88a5c46d
--- /dev/null
+++ b/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Dictdiffer is a library that helps you to diff and patch dictionaries"
+HOMEPAGE="
+ https://github.com/inveniosoftware/dictdiffer/
+ https://pypi.org/project/dictdiffer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Requires self to be already installed
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # remove dep on pytest-runner
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ # remove dep on pytest-pep8 and pytest-cov
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}