summaryrefslogtreecommitdiff
path: root/dev-python/dict2xml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
commitbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (patch)
tree7154de118466f928d847a0659795c3f84c116096 /dev-python/dict2xml
parent1e17db840dfd2f8b2b43a0a385c106812ebcfea9 (diff)
gentoo auto-resync : 25:02:2023 - 09:51:58
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/Manifest2
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.3.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dict2xml/Manifest b/dev-python/dict2xml/Manifest
index fac7c3319b45..181d17968764 100644
--- a/dev-python/dict2xml/Manifest
+++ b/dev-python/dict2xml/Manifest
@@ -1,3 +1,5 @@
DIST dict2xml-1.7.2.tar.gz 12295 BLAKE2B 7bd1c771f3b1c38f96bb322f88d78fb4ab763b153a0531f1953ad97e4b8eb93464a4cfb2aeaffc1599967145a54f0decc5152f3084587f6d94f25cdcbd5837c1 SHA512 fea3a65c5decfee8a22135fc262764c9afbc6b9f41232557f2de1b18a5b30e65c6910ef9f7d4e4b22c2d6c27d5b18eb6a83679c656564061bb7e5e8c55945c76
+DIST dict2xml-1.7.3.tar.gz 14240 BLAKE2B b28343f2cfeb59a91011bb158ffe7db008f19be1576293e6b07c3b49e07f3871761c8a3a32c214bf0608602487e2e7110c7f2a2f31a7dbf44a441f44ca7f568b SHA512 631415e425688c612c15b72fc339db33977df32eb25f7f8f03a63e5115c8e06f4aa5b247ded3e16cddbb9b16597aeb0ef218f193c5f4c44ebdcd7e39c2052ed2
EBUILD dict2xml-1.7.2.ebuild 552 BLAKE2B 6778503fe419593d90d2b845a35742fef4773e325cbe9e5dec232c6419fa100f32f8a8af50ad1edede99e84cf42caa35ce16c352fbe85d8167a55fb9393fb471 SHA512 ea17888490e32d5bd688765d5f34e80282942e4e3a83558baab3abc8a7129cf0ac33441b39bac0bc40b135fb09e1687f5b3793ea06c65470b60c2568cfaaea8b
+EBUILD dict2xml-1.7.3.ebuild 541 BLAKE2B 7b17797029aac2785c312746e86444178ffca46d85b1310e291f2e196fb2a86da1a035cb1ef2aa47cc065dddb5e909c80660c28e1627d1750fcc97d0618b7ec6 SHA512 14cec564d7a59a48ef1ec254a8ce8b68409b7ced1940273b915b01a0e9a946f0a9f153d5541c89e144d9a7302a33fc4833715219231c40518dafae11c18b5951
MISC metadata.xml 483 BLAKE2B 590704cfc7c04bef7ac3b4b01677c743887a19c842597a81a12d374c0126ac4feb5ecf3ee6a1b2ee8bb866a2823ecd5e4c556f3ddf512bff00d047d40ee33929 SHA512 175a0080449e7a29aae0398303911acf868bc9a444eb2883d4cca071ac1daafda2ad352274c33516fe06f11ce8bdc029d1e277a8455a3819ff51650388ed11cd
diff --git a/dev-python/dict2xml/dict2xml-1.7.3.ebuild b/dev-python/dict2xml/dict2xml-1.7.3.ebuild
new file mode 100644
index 000000000000..97a64fe6615e
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest