summaryrefslogtreecommitdiff
path: root/dev-python/deprecation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/deprecation
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/Manifest2
-rw-r--r--dev-python/deprecation/deprecation-2.1.0.ebuild15
2 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/deprecation/Manifest b/dev-python/deprecation/Manifest
index 59bebbeb00b8..7038404372b9 100644
--- a/dev-python/deprecation/Manifest
+++ b/dev-python/deprecation/Manifest
@@ -1,3 +1,3 @@
DIST deprecation-2.1.0.tar.gz 173788 BLAKE2B 444c7ff688d6eab7dfcf58ad24580b5a6df39a5749341b28d6d5b9b516fd6aa7a462d7f644e6cba596bbf289be0224968f579837c6c71dbe7b36b65588da6eea SHA512 c184665d210c6eeb3f055b23e75c3714f3b18050e03bfe1384baf6c2504f1370116ae0e8c53ff818ccc54c0d633bbb3ba5791fe20b8029f3be0207b019a00275
-EBUILD deprecation-2.1.0.ebuild 599 BLAKE2B 1b3084756fe090a7373da6da3b6a51f27b65869c971504d98b52d7135c6fffaccfd2da5e2a7dba242632e7c46519733de4f79af3fa91a8d31530124c08e75ddd SHA512 02690601778268c0f13e6b7dcf23ce96f42698eaac773e4360725d4bdfa8a28de80ed39ac6c2c562495d83deecc34b6aec516074d8a157218ab083f0a9f5f0a2
+EBUILD deprecation-2.1.0.ebuild 647 BLAKE2B 3ffa5d552429ebb8667eb784dec51139ae5338ee04fd5e71943ab34c38e230b3926677dff6c58739c62cd676e1bd75c8d1d0d69cbe45db255c85335cde682dd9 SHA512 25790f808a62ccb9e8a0cd335ea5515099c69dbf649f8c1681b1c679b86149d58fda23d712476bd68dacc94412579c079710abb95034475135a068a3215c801d
MISC metadata.xml 565 BLAKE2B 007c1977dff6e93c49877fbd0a41e12f7b59e73b12dd8cbd0ee309860195ab560b9bbb3f52b861be6742d5e8f1b78564eb69f74cf53e121e7c9df2a2e58f0f8d SHA512 89374b3c32bbf7f35e585295cfd13c50019304f2620a4b8745b20f0e37b87abc04c7fa464b9277630a723a1a0d4a6a9460f85b87c902285ad4033519e6ad5120
diff --git a/dev-python/deprecation/deprecation-2.1.0.ebuild b/dev-python/deprecation/deprecation-2.1.0.ebuild
index 435613b78604..27e83e0c5858 100644
--- a/dev-python/deprecation/deprecation-2.1.0.ebuild
+++ b/dev-python/deprecation/deprecation-2.1.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A library to handle automated deprecations"
@@ -16,11 +15,11 @@ SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
-"
distutils_enable_sphinx docs
distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e 's:unittest2:unittest:' tests/test_deprecation.py || die
+ distutils-r1_src_prepare
+}