summaryrefslogtreecommitdiff
path: root/dev-python/denonavr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
commitbb17db5f98333b3c74b4194d1c1136144f693add (patch)
tree65d7446b00fbeb21e2dd8dc4c106526dd4a8fb7d /dev-python/denonavr
parent1e9275d80771f014d7754407ca8ab9d7c43247b0 (diff)
gentoo auto-resync : 24:10:2022 - 09:51:42
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest2
-rw-r--r--dev-python/denonavr/denonavr-0.10.12.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index adb53e95a78a..4faee7f3f5f2 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,3 +1,5 @@
DIST denonavr-0.10.11.tar.gz 157622 BLAKE2B aa311eff51dbba857f529aee1a1931b3456b7c42f4710d21aff0eb6cf21718d639795d8099e8b0ad297787ba887746b265f922c19afe692cc3317291023a2df3 SHA512 19a10196019067605a2565be4ee0dc56116d6f706ca97c6754e6dc63cccc8870ee657736fd17f1959753c1c24c878e0d7a721c33212e6753dc12b5fc7dae34e0
+DIST denonavr-0.10.12.tar.gz 167623 BLAKE2B b0d12782e21cf08ba72e069e4952d2c531669de7f357af34f8aa3254cb67c80b75989f67a37281420e7dbb7929082a92327ebf1bb744539e9d2396117ff54714 SHA512 791205d4b367f05388a262935c3e24086cf1603eafc65881fa31e323e9c16c4ac6fd9f09672586fffc63a7a306556183732d71820f05e7c6c66cf17cb33af9c4
EBUILD denonavr-0.10.11.ebuild 904 BLAKE2B cf0e90af3c4687a08aea95fd5c6c03d5b38b18db0f6f678173f58ea2a336812e61ea6e5a4eb8b9d1227dfcb85d0807983dfd96f308e79545fd2ffcb0562bd49b SHA512 487baaf916687e307545add692741cf7a93ec7500302857b366c62b372dbe12e99e26ea476d8c1a85863b42af0354d2088795c986c0447880219e5fc139f9aec
+EBUILD denonavr-0.10.12.ebuild 904 BLAKE2B b771f08ddfec21ecb41d802092be34283f8cf445a555aa85092a4d1d3a0dcb52feff4886ef6227493f8fbe7810f8bf2a858f78cdfc643a8219c08d74e15f8036 SHA512 491341e899a1acdf97792c5e35d055a7745698c73494322b91c0536494a8a2a4f87bb575d56c01613dbe7605e29d0099c8431fd56c80d1e12dea25ae87b81e5a
MISC metadata.xml 538 BLAKE2B 7f0ea063a1ebe7cfbab11a8e92b803606c6454ea9bf871bc804f048a58b35e0ab66eafbee64d8d4328e4e3cd5361a810527813c48aba212950f263da2b4454cf SHA512 3531537b37f09f4b0d27d124d1bc698d8b8eeb410a0f3504f315a8002a8443a886959706e437359796623f3462b3d12d89ad677fbde73ee6081c61ed01663ad4
diff --git a/dev-python/denonavr/denonavr-0.10.12.ebuild b/dev-python/denonavr/denonavr-0.10.12.ebuild
new file mode 100644
index 000000000000..7f99008f42e8
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.10.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest