summaryrefslogtreecommitdiff
path: root/dev-python/denonavr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
commit47bb4031ea0e98a9423d423f2181c0e3d06f256b (patch)
tree6a54fb70ac916b8ae725d002ac4a71386c8b6e2f /dev-python/denonavr
parent9a1d1c6b10a4640cea10e7040ed173cf593f4cab (diff)
gentoo auto-resync : 23:01:2023 - 12:55:07
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest2
-rw-r--r--dev-python/denonavr/denonavr-0.11.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index 9a9f14cd11a4..05fce538f6d0 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,3 +1,5 @@
DIST denonavr-0.10.12.tar.gz 167623 BLAKE2B b0d12782e21cf08ba72e069e4952d2c531669de7f357af34f8aa3254cb67c80b75989f67a37281420e7dbb7929082a92327ebf1bb744539e9d2396117ff54714 SHA512 791205d4b367f05388a262935c3e24086cf1603eafc65881fa31e323e9c16c4ac6fd9f09672586fffc63a7a306556183732d71820f05e7c6c66cf17cb33af9c4
+DIST denonavr-0.11.0.tar.gz 171742 BLAKE2B b91008a8eebcc0e228db772f2fe2d0bcd3fe7cc036d8aab2c547698224e63e0cbea2d9e9dcb5244556712ab5e04cb9c5e06731eba93a37061536668065c03931 SHA512 63624ec23db6e953741f4610a7df22fa0a69ae750957e883f0447c7a193c28e3a70245547f270c05bf93fdaca2c22b1fc5147b5e2b886c28049faf7f02b6bcb2
EBUILD denonavr-0.10.12.ebuild 904 BLAKE2B 5ece0c4d3a5da58d449a30d3d5affe7b374ad36a97df57ea822b4640c87ac87fd32f8a98075f67924059c12ab6637ccf422fe37bd69f537119e4f3f9c17e2b1e SHA512 df88c31329c8cfc5e0feeac7a88307ff7ea5ae2cb40ea676d8f42d408221c31eb50a9b9afd96511a565119ccd4da1264d1dba9d3c351a558d2ba65a5f390610f
+EBUILD denonavr-0.11.0.ebuild 1051 BLAKE2B f4911759a899a1a20f600e3cdacf46d374a3147a09bbac172c87d57e61e2a44f26394e685b7af6d190f0f982920e8ea00bb49a38fd2831b2648cace44085cc60 SHA512 c28a974cb26c048199237cabee1e639aa825db02c33abc60eb512bbc1f25fcb39acc03a787a1a762b916deb8be08214d9f9d318d9542572f60b41b5486b253b5
MISC metadata.xml 538 BLAKE2B 7f0ea063a1ebe7cfbab11a8e92b803606c6454ea9bf871bc804f048a58b35e0ab66eafbee64d8d4328e4e3cd5361a810527813c48aba212950f263da2b4454cf SHA512 3531537b37f09f4b0d27d124d1bc698d8b8eeb410a0f3504f315a8002a8443a886959706e437359796623f3462b3d12d89ad677fbde73ee6081c61ed01663ad4
diff --git a/dev-python/denonavr/denonavr-0.11.0.ebuild b/dev-python/denonavr/denonavr-0.11.0.ebuild
new file mode 100644
index 000000000000..d5846bc80fc7
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+ # https://github.com/ol-iver/denonavr/pull/240
+ rm -r "${D}$(python_get_sitedir)/tests" || die
+}