summaryrefslogtreecommitdiff
path: root/dev-python/defusedxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/defusedxml
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/defusedxml')
-rw-r--r--dev-python/defusedxml/Manifest3
-rw-r--r--dev-python/defusedxml/defusedxml-0.7.1-r1.ebuild40
-rw-r--r--dev-python/defusedxml/defusedxml-0.7.1.ebuild4
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-python/defusedxml/Manifest b/dev-python/defusedxml/Manifest
index 0862e76f9f94..767143c4cd71 100644
--- a/dev-python/defusedxml/Manifest
+++ b/dev-python/defusedxml/Manifest
@@ -1,3 +1,4 @@
DIST defusedxml-0.7.1.tar.gz 34709 BLAKE2B cfe69851e0ac6472cb9e66d1b577831eec37b0a01129dcb43cec151aa939029efc194220f3c7b481d306a77db710a639bdd56f3fd1f7ae46fa4ab8f308b8036f SHA512 4f536794b814291520c7db27765014c57f415554cff569cddab596b33e1aa03799aae9448fdaf07417d1a9f4d8782aa827d1b68aac6881ffe5c2ca9b8a40d864
-EBUILD defusedxml-0.7.1.ebuild 771 BLAKE2B a3bb6f93688ff5b8d75baebd9a334e00c914ef6f99407615fbbd2281ece425def5ac03df5d5925312e1ad56fa756e8cf0a33e4fa0550b9b9e96b40150f3c885a SHA512 2e144d902d647f686cb1d970db5930738e15946647c4c3758cd94a4564367f91ed66b2239fd969a310f4a7da63b31257cc58f3775bd1eb82b4f8630d9e005e89
+EBUILD defusedxml-0.7.1-r1.ebuild 921 BLAKE2B 31bcd13fca03b64de1b171cdd7d939a03037b0af3a6b31241c50b9403e76a552555d065a369d70c40c14ed18ebf7aa5e203ffab63f2e1fc4eb86bc824f1fbc83 SHA512 0713829daae6511036a484bd3f84f165634d49729379ec581879c4f992452635e6b4e767f7240900676d318613b55225dc81bdf5ef8caf9c622986b666062436
+EBUILD defusedxml-0.7.1.ebuild 778 BLAKE2B 622554549f672f5cff6a0c4c13635f4b7d6355fd3ff219c226474c6cb24b30717fbafca894bcf8ca179cde45a834cf2e61e578587e79b816e7811ef2bd41ceab SHA512 eafd9610083f16effb5b76ad4ceefa91016c68ef61e509692c0674919800d94fcb1d2d08ff74ab06c0ef48e7852d1cefae6377ed0fdf66445ee01b9720a8ae9f
MISC metadata.xml 407 BLAKE2B 7bdbcb75f81a2de2438c5fb0be0f3a5a634b4ba31b3e32eae6a4094bda9b00ada4c779b8c0884ab0442ff09d3f0ad27ea7de851adff94c320bb6e75c8a499f6b SHA512 a47ffd89a479f85548aa4ce42ea525cb0685acc7c0b83ba74ecaa16d1145912409a4cfe4473297a2923bf4875e567489d5c72a10ddf485e0258605d1c4109f0a
diff --git a/dev-python/defusedxml/defusedxml-0.7.1-r1.ebuild b/dev-python/defusedxml/defusedxml-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..b48784799f81
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.7.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="
+ https://github.com/tiran/defusedxml/
+ https://pypi.org/project/defusedxml/
+"
+SRC_URI="
+ https://github.com/tiran/defusedxml/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:verbosity=1:verbosity=2:' tests.py || die
+ mv other examples || die
+}
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples/
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/defusedxml/defusedxml-0.7.1.ebuild b/dev-python/defusedxml/defusedxml-0.7.1.ebuild
index b1e56c450258..467e26e24293 100644
--- a/dev-python/defusedxml/defusedxml-0.7.1.ebuild
+++ b/dev-python/defusedxml/defusedxml-0.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ S=${WORKDIR}/${P/_/.}
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples"
distutils_enable_tests setup.py