summaryrefslogtreecommitdiff
path: root/dev-python/debugpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
commitc107831b9ebfe892c139cdb68d747eea369d8588 (patch)
tree3e2fbc0ea06bf0ea7a5fdf0250036433cd4bc11f /dev-python/debugpy
parent52895d302231ef73b105756d2781b2262638d566 (diff)
gentoo auto-resync : 02:02:2023 - 21:08:25
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest5
-rw-r--r--dev-python/debugpy/debugpy-1.6.6.ebuild43
-rw-r--r--dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch77
-rw-r--r--dev-python/debugpy/metadata.xml1
4 files changed, 125 insertions, 1 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index f3673815c1ed..04ff976fc03f 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1,4 +1,7 @@
AUX debugpy-1.6.1-unbundle-pydevd.patch 2908 BLAKE2B 2c9ef22ce4e00f8a7bafa4097bfbcaf4218195df9f6243233da2d713c819af40251d9a5b0d150a0d7e1615fa128ae36236aae0440791e6f5e1ccd6376f2c1192 SHA512 5f4938171f6edfbf093032ddd3711f112c90e350ca26287edc70cda0668aece98075ab34721e1734ba7c9e72c9a5df774e3683e230c15533e32dc9798329647f
+AUX debugpy-1.6.6-unbundle-pydevd.patch 2531 BLAKE2B c7cf5cc10a75393b191ab3ecd3137b2d4df30a0611b76fd18bf1822aa61c06ec912358afe6da420c1ace3314e12b57079cadb0deebeb19fc3242f75f7ef5860a SHA512 98d6557c516617273a1a75c5269733f02d55754078ba9a5137f9abdcddc58275a7ea451f290ecf809003abc614b0865d235a8b712caec71e3811911a4f231448
DIST debugpy-1.6.3.gh.tar.gz 6697583 BLAKE2B 38138be3294615e78995575c8f8ad1f990733be90cfaf76197c714e84f179086501417cc2d64627d3a8ecd0fa451e14e3229bd14d02353bc7512e288e8d4f092 SHA512 c055351351f6705b7bbab93ec07abba09027f1f2a52d90a242f51b4eb6fec19821fbb251b8c8e80587d1333faa4c6d7cab5dead938e9739c5c45013af8ee46a7
+DIST debugpy-1.6.6.gh.tar.gz 6942488 BLAKE2B 18c6eee2322239e5cbbacf9431fa7480abcf14a68f290d2228edc8b2ead042e7b09d19ee5bcc60be32e8a6b0b34b925eaa8246991298744f3ca74d4ed2ea3f3e SHA512 1a209bfd702d5f0649ce50b0910023e295953dd39cefdefb0b5af1d6023e629a727610789cd244e656bdf4276cee957fa463506ddaca603ab3ee85cc250dc212
EBUILD debugpy-1.6.3.ebuild 1145 BLAKE2B a3c641fab5ea9ffdc1ac452fcc83810a02b48fec1adbe7cd85d1296eddcced63a1ba1601efc4671f3924c7384b5df7200dae1c8d215b373e4508d4604648ce2d SHA512 779369fcbfa80d0b85a4d9ac08c87b406599b07018e439aa8c2d8be1d4f99d3086459f48b1052a1eaab49de8f0004611e849427b28a54d4b34629731e58d936d
-MISC metadata.xml 451 BLAKE2B 671153316362e0394ae59824e67f5ea897615d3853552aa92fb273d4a41a88916cfe03650ab42248ffee557cb95149b21160395e0fcb2f1fd69bb3bc2c97ea55 SHA512 393d4898c3555b425c34dad5f540f42fc8e281f6299360d1192d099e73486467c92ed16ca710e34d2868aec63fca2eab4775b86e95e6dea79b8721ff70e1db87
+EBUILD debugpy-1.6.6.ebuild 1153 BLAKE2B e0687e6ba401b4bd49de9684dacbdd31aa485b308f20325d434f961570ed913efeb902c51018719ed511e5ba3ae808104d796ba87a9cff97d56e7162f594c6a8 SHA512 f84b9f6ff46bd39338072796f465889ebab5f8b124c590e35f1babe72300ede342627b75b276b2c40b7d4c85915237d174a5b12751fbeda93699d8bae17e9810
+MISC metadata.xml 508 BLAKE2B f5af1472be02222c1eb89246c4c4b782aaf5de8dd785aa983bbee6df69982b96c276310480a7ffbf2ac0105268507474d3b0823fc9e0bff89acfe648a2cc490f SHA512 d4697748bc79f4c684dd3bf58e52b211e8ba7816041840e705b896f2731a1a0518a01d7b7cca5e441bbc88e6eb272175c26681517873883068c4fe1bc864c09b
diff --git a/dev-python/debugpy/debugpy-1.6.6.ebuild b/dev-python/debugpy/debugpy-1.6.6.ebuild
new file mode 100644
index 000000000000..8579d79609a8
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.6.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# This is completely broken
+RESTRICT="test"
+
+RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.6-unbundle-pydevd.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
new file mode 100644
index 000000000000..d285775c9246
--- /dev/null
+++ b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
@@ -0,0 +1,77 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 9a79e55..8725d19 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -8,7 +8,6 @@ exclude = '''
+ ( __pycache__
+ | ^/.tox
+ | ^/versioneer.py
+-| ^/src/debugpy/_vendored
+ | ^/src/debugpy/_version.py
+ )
+ '''
+diff --git a/setup.py b/setup.py
+index 3abc811..c11924c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,12 +18,10 @@ del sys.path[0]
+
+ sys.path.insert(0, os.path.join(os.path.dirname(os.path.abspath(__file__)), "src"))
+ import debugpy
+-import debugpy._vendored
+
+ del sys.path[0]
+
+
+-PYDEVD_ROOT = debugpy._vendored.project_root("pydevd")
+ DEBUGBY_ROOT = os.path.dirname(os.path.abspath(debugpy.__file__))
+
+
+@@ -146,8 +144,6 @@ if __name__ == "__main__":
+ extras["platforms"] = platforms
+
+ cmds = versioneer.get_cmdclass()
+- override_build(cmds)
+- override_build_py(cmds)
+
+ setuptools.setup(
+ name="debugpy",
+@@ -183,14 +179,9 @@ if __name__ == "__main__":
+ "debugpy.common",
+ "debugpy.launcher",
+ "debugpy.server",
+- "debugpy._vendored",
+ ],
+ package_data={
+ "debugpy": ["ThirdPartyNotices.txt"],
+- "debugpy._vendored": [
+- # pydevd extensions must be built before this list can be computed properly,
+- # so it is populated in the overridden build_py.finalize_options().
+- ],
+ },
+ ext_modules=ExtModules(),
+ has_ext_modules=lambda: True,
+diff --git a/src/debugpy/server/__init__.py b/src/debugpy/server/__init__.py
+index 42d5367..e333dcf 100644
+--- a/src/debugpy/server/__init__.py
++++ b/src/debugpy/server/__init__.py
+@@ -1,7 +1,3 @@
+ # Copyright (c) Microsoft Corporation. All rights reserved.
+ # Licensed under the MIT License. See LICENSE in the project root
+ # for license information.
+-
+-# "force_pydevd" must be imported first to ensure (via side effects)
+-# that the debugpy-vendored copy of pydevd gets used.
+-import debugpy._vendored.force_pydevd # noqa
+diff --git a/src/debugpy/server/attach_pid_injected.py b/src/debugpy/server/attach_pid_injected.py
+index a8df6e1..a29a969 100644
+--- a/src/debugpy/server/attach_pid_injected.py
++++ b/src/debugpy/server/attach_pid_injected.py
+@@ -31,7 +31,6 @@ def attach(setup):
+ pydevd_attach_to_process_path = os.path.join(
+ _debugpy_dir,
+ "debugpy",
+- "_vendored",
+ "pydevd",
+ "pydevd_attach_to_process",
+ )
diff --git a/dev-python/debugpy/metadata.xml b/dev-python/debugpy/metadata.xml
index a55c596e2ffb..a6c53f2a9008 100644
--- a/dev-python/debugpy/metadata.xml
+++ b/dev-python/debugpy/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">debugpy</remote-id>
+ <remote-id type="github">microsoft/debugpy</remote-id>
<maintainer status="unknown">
<email>ptvshelp@microsoft.com</email>
<name>Microsoft Corporation</name>