summaryrefslogtreecommitdiff
path: root/dev-python/debugpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
commit91e1f8a90b85372d757efd9a1fb7dd1685ea6b50 (patch)
treeebeff59a4470abb242c47417f217e36e21fe6a0c /dev-python/debugpy
parentae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (diff)
gentoo auto-resync : 17:08:2022 - 02:31:41
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest2
-rw-r--r--dev-python/debugpy/debugpy-1.6.3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index c5110f18da81..3803ddb727f4 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1,4 +1,6 @@
AUX debugpy-1.6.1-unbundle-pydevd.patch 2908 BLAKE2B 2c9ef22ce4e00f8a7bafa4097bfbcaf4218195df9f6243233da2d713c819af40251d9a5b0d150a0d7e1615fa128ae36236aae0440791e6f5e1ccd6376f2c1192 SHA512 5f4938171f6edfbf093032ddd3711f112c90e350ca26287edc70cda0668aece98075ab34721e1734ba7c9e72c9a5df774e3683e230c15533e32dc9798329647f
DIST debugpy-1.6.2.gh.tar.gz 6684477 BLAKE2B ab1bdf394d3447ba347db149e5c4c36820df6df24c5d0984fe862419a490cea21b240322d76644bc9ebadbdf9a6d6c8709ae28452828d42b45d65edd2d2e58cb SHA512 64ecd9f8290588358abcff538f2c68025f14efc38ac5b406f32cd40a580aab90e0b2f145de90ca81943872c70969d6294ac51b3151bc4e03f18370ddfbb9ac6c
+DIST debugpy-1.6.3.gh.tar.gz 6697583 BLAKE2B 38138be3294615e78995575c8f8ad1f990733be90cfaf76197c714e84f179086501417cc2d64627d3a8ecd0fa451e14e3229bd14d02353bc7512e288e8d4f092 SHA512 c055351351f6705b7bbab93ec07abba09027f1f2a52d90a242f51b4eb6fec19821fbb251b8c8e80587d1333faa4c6d7cab5dead938e9739c5c45013af8ee46a7
EBUILD debugpy-1.6.2.ebuild 1132 BLAKE2B f2478be8d88ce9913a8ede1a2240f5a0e591884fee336d3b8633ee3d11ca18fff0eb882e1bc98972876eea6269c951bc4f7dbfb6ef517964cf101e9afac46079 SHA512 320dc027166702f0fef87f419827e57a9aacb3f2e1157bdda5dcc7c9c752d40740c7389e695f19af91ef68717be2fc1d5fd6d29c1d12c8b03f0caf9c74396f67
+EBUILD debugpy-1.6.3.ebuild 1140 BLAKE2B c7f27f9699c7f841bd6dd862161b21cefce64591e0804e95d57bdae70a0f0f7c5b31abe85ba688b7386918dd9026f9fcc0740208bcaff4d49254f7d8163f690d SHA512 cd4e41d850a93ea169fa20542c38bac0c280ca8dbb0f186a48105c63a7ab96f067c6c60696c76189b90e264b45b1d58e62db4bb9e167680b46c672011f5d9fd5
MISC metadata.xml 451 BLAKE2B 671153316362e0394ae59824e67f5ea897615d3853552aa92fb273d4a41a88916cfe03650ab42248ffee557cb95149b21160395e0fcb2f1fd69bb3bc2c97ea55 SHA512 393d4898c3555b425c34dad5f540f42fc8e281f6299360d1192d099e73486467c92ed16ca710e34d2868aec63fca2eab4775b86e95e6dea79b8721ff70e1db87
diff --git a/dev-python/debugpy/debugpy-1.6.3.ebuild b/dev-python/debugpy/debugpy-1.6.3.ebuild
new file mode 100644
index 000000000000..87982f97e4bb
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.6.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# This is completely broken
+RESTRICT="test"
+
+RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.1-unbundle-pydevd.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
+
+ distutils-r1_python_prepare_all
+}