summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/dbus-python
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest2
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index d54ea84ab3b9..539ecbb739d0 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,4 +1,4 @@
AUX dbus-python-1.2.16-py39.patch 948 BLAKE2B df88f38be549b81b404f3e5e7f0d4c09f7c43bc9ee91b0534059fbb3edbbe675e7ecd467d5d57f365aa59d510f06c41c9ae4970a5e5e8d2fad109bf55cfb507d SHA512 ce5f419736dea09de8a58e372c7587afbd270d806bdcc0eb3b7bd5fa830be00453152ea7ea44a32a06d860ca3174282f62ef44d5f8c9d43de7d8724c69f2ab37
DIST dbus-python-1.2.16.tar.gz 576701 BLAKE2B 58d9f9ea092cd3a6b872c084a6159baf03f1aab615282e161a0e3da1d01ff5f4940862e693d21907b0c146d285b9067386759a1306ae2e6907f5e2ff4ef9944d SHA512 e76c00c5fd3fe6884e4c24f258987fd3b80d21bd4e0f96aa8fda152078a860b62321324f6efcbfe7226d5ab2521a14b5bda7cf2468d2cae5f376c124a71aa05c
-EBUILD dbus-python-1.2.16-r1.ebuild 1741 BLAKE2B 775079c1fb18a829c519e51353c0c0c035654c938d234e44c081b2b157f838eb1626d63c8862b42d35c8eab209499ca5164e847b43b41e4c19326b3b0ab6b58f SHA512 13f0d1e731a8faee3c69dc70306c863a6312d7359a66c7b8e4cb1a72fd29f6864492d10ffcfbd5710ad696f897f658c93c72d0202b4969588ef42369d2615ff5
+EBUILD dbus-python-1.2.16-r1.ebuild 1859 BLAKE2B 86db78f539efdbb43116b63a1ab2bb7f3794d98b19dd4e4c5612f272f2ca0f27d320219ad4ef2fc25bf1111eb7df54720e3d0698d0928c6b8f096e174191eefe SHA512 0d1d9eef3a8ae2caf49d620d308acb821d3a19b9a822ec857c66eb57cac990e2f4d9a726be92886bf759b3b8516a6cba1844fc90ef52418992dab12787a14922
MISC metadata.xml 403 BLAKE2B 016856f2fe17f2036e04502f85ffcd605d52556ddf50baf50fa431548b57914994f03f159ed01beaba1409daf0b4192e6101d4e62db73a75944ed0550943f2cb SHA512 a7a70f0a2430894661a3324d32a091b8f9473170c2dc073a4dca269b29e19507b753f09aee212ef47c13e1f89e9d1ae41d0f50b96da211bc3afcc4d51dd94e6a
diff --git a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
index 2a6f8bd59269..dc7eb8eeea93 100644
--- a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -28,7 +28,10 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
+ doc? ( $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ') )
test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/tappy[${PYTHON_USEDEP}] )
"
@@ -37,6 +40,7 @@ PATCHES=( "${FILESDIR}/${P}-py39.patch" )
python_check_deps() {
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
}
src_prepare() {