summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/dbus-python
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest3
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16.ebuild4
-rw-r--r--dev-python/dbus-python/files/dbus-python-1.2.16-py39.patch33
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index aed41f23f6b4..fd0c7680b52f 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,3 +1,4 @@
+AUX dbus-python-1.2.16-py39.patch 948 BLAKE2B df88f38be549b81b404f3e5e7f0d4c09f7c43bc9ee91b0534059fbb3edbbe675e7ecd467d5d57f365aa59d510f06c41c9ae4970a5e5e8d2fad109bf55cfb507d SHA512 ce5f419736dea09de8a58e372c7587afbd270d806bdcc0eb3b7bd5fa830be00453152ea7ea44a32a06d860ca3174282f62ef44d5f8c9d43de7d8724c69f2ab37
DIST dbus-python-1.2.16.tar.gz 576701 BLAKE2B 58d9f9ea092cd3a6b872c084a6159baf03f1aab615282e161a0e3da1d01ff5f4940862e693d21907b0c146d285b9067386759a1306ae2e6907f5e2ff4ef9944d SHA512 e76c00c5fd3fe6884e4c24f258987fd3b80d21bd4e0f96aa8fda152078a860b62321324f6efcbfe7226d5ab2521a14b5bda7cf2468d2cae5f376c124a71aa05c
-EBUILD dbus-python-1.2.16.ebuild 1701 BLAKE2B 76afc20e2b0e5a76c4e43e1bc4e875744eb74011752827ef038a69670444f74a296d1f04a09d726d22a916576b9f3b8e6291a263983982f14be1022b5a420a03 SHA512 b9861ea5c126bda423a19f623045b0a4cc1b66ab27d48c45e39f03145dd54b7b1af994a62b0d2f486da698ebb3392b2d534ec585584af7a60dc8aa4a88399538
+EBUILD dbus-python-1.2.16.ebuild 1746 BLAKE2B 46f2f65358f3760e8df721ab4aca351745829ba690d9544294543a3f8494671ea1865d7f77583d6755d90e04473128ce796e25fab26399335d02971dd60894a7 SHA512 96a9e48911f2fe44d14ca889789d9c8ea3d2d02fba3c6b3115f3844611343878dce69ca878aa3dbe368fb04e5a2e98d0ea4aad2d1594eed231278f2760247e59
MISC metadata.xml 337 BLAKE2B 96d3f5d7c37edb1a63791e013c39cf5b10c94d621ad851f9975d9d5e36519da135bf963f2a0e38c2c098fa48c2056bf210bdfcebc12bb10a88c9e9f85c55eb2a SHA512 633761250e946af99fcbcbf813b70fa0b1e03a0d89102faa3f324c418f0e749371aa931d253dc5a6f69369c25acc2d50a0f5e2155bd727766bc70f4bc3933d65
diff --git a/dev-python/dbus-python/dbus-python-1.2.16.ebuild b/dev-python/dbus-python/dbus-python-1.2.16.ebuild
index d7512b4dc8f8..e07d2500f718 100644
--- a/dev-python/dbus-python/dbus-python-1.2.16.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.16.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
@@ -33,6 +33,8 @@ BDEPEND="
dev-python/tappy[${PYTHON_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/${P}-py39.patch" )
+
python_check_deps() {
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
}
diff --git a/dev-python/dbus-python/files/dbus-python-1.2.16-py39.patch b/dev-python/dbus-python/files/dbus-python-1.2.16-py39.patch
new file mode 100644
index 000000000000..93db26cfcefc
--- /dev/null
+++ b/dev-python/dbus-python/files/dbus-python-1.2.16-py39.patch
@@ -0,0 +1,33 @@
+From 6a899a9174c8008ba5fb576238ea4d7c970453c3 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@collabora.com>
+Date: Tue, 14 Jan 2020 15:29:43 +0000
+Subject: [PATCH] service: Adjust to deprecation of collections.Sequence
+
+Since Python 3.3 the recommended location is collections.abc.Sequence,
+and the collections.Sequence alias will be removed in 3.9.
+
+Signed-off-by: Simon McVittie <smcv@collabora.com>
+---
+ dbus/service.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/dbus/service.py b/dbus/service.py
+index fd57054..0c8695a 100644
+--- a/dbus/service.py
++++ b/dbus/service.py
+@@ -32,7 +32,11 @@ import sys
+ import logging
+ import threading
+ import traceback
+-from collections import Sequence
++try:
++ from collections.abc import Sequence
++except ImportError:
++ # Python 2 (and 3.x < 3.3, but we don't support those)
++ from collections import Sequence
+
+ import _dbus_bindings
+ from dbus import (
+--
+2.26.2
+