summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/dbus-python
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest2
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.18.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index 539ecbb739d0..c913d692162f 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,4 +1,6 @@
AUX dbus-python-1.2.16-py39.patch 948 BLAKE2B df88f38be549b81b404f3e5e7f0d4c09f7c43bc9ee91b0534059fbb3edbbe675e7ecd467d5d57f365aa59d510f06c41c9ae4970a5e5e8d2fad109bf55cfb507d SHA512 ce5f419736dea09de8a58e372c7587afbd270d806bdcc0eb3b7bd5fa830be00453152ea7ea44a32a06d860ca3174282f62ef44d5f8c9d43de7d8724c69f2ab37
DIST dbus-python-1.2.16.tar.gz 576701 BLAKE2B 58d9f9ea092cd3a6b872c084a6159baf03f1aab615282e161a0e3da1d01ff5f4940862e693d21907b0c146d285b9067386759a1306ae2e6907f5e2ff4ef9944d SHA512 e76c00c5fd3fe6884e4c24f258987fd3b80d21bd4e0f96aa8fda152078a860b62321324f6efcbfe7226d5ab2521a14b5bda7cf2468d2cae5f376c124a71aa05c
+DIST dbus-python-1.2.18.tar.gz 578204 BLAKE2B 932a06f4b0145f7a47cf1ab6ea33c14eb4e36570ef548e7557d4aa5b780e49f2d284cdb51f0ec2d8a1cb286097fb9eabb2193d7cbeb387eaf43cbe209b7f11fa SHA512 72f422c59637392bd78b741b66dff2afadcc706452c3e82fdc14b1dc052a0c5cb8a85e2758d18c5cbdc08004419a0b3c16b67b99688d96307084403e72585900
EBUILD dbus-python-1.2.16-r1.ebuild 1859 BLAKE2B 86db78f539efdbb43116b63a1ab2bb7f3794d98b19dd4e4c5612f272f2ca0f27d320219ad4ef2fc25bf1111eb7df54720e3d0698d0928c6b8f096e174191eefe SHA512 0d1d9eef3a8ae2caf49d620d308acb821d3a19b9a822ec857c66eb57cac990e2f4d9a726be92886bf759b3b8516a6cba1844fc90ef52418992dab12787a14922
+EBUILD dbus-python-1.2.18.ebuild 1824 BLAKE2B 8ffa7ce9b9c8af5369986e6f1ca60245e6786bc66bfea1a6d28e828a4b1d238e90a3a5f122a703fd051c3633c502188d4764f21c4d2d790450c0ce05da788fd9 SHA512 736ad634ad4732fdd8d430dfdde196055d507ec0a448c2e7a0b19de79ad3c85047918f102113d705fbbafd9a81e29d67c0dcdd1c5ab69feb88e056f7c0d5cfb4
MISC metadata.xml 403 BLAKE2B 016856f2fe17f2036e04502f85ffcd605d52556ddf50baf50fa431548b57914994f03f159ed01beaba1409daf0b4192e6101d4e62db73a75944ed0550943f2cb SHA512 a7a70f0a2430894661a3324d32a091b8f9473170c2dc073a4dca269b29e19507b753f09aee212ef47c13e1f89e9d1ae41d0f50b96da211bc3afcc4d51dd94e6a
diff --git a/dev-python/dbus-python/dbus-python-1.2.18.ebuild b/dev-python/dbus-python/dbus-python-1.2.18.ebuild
new file mode 100644
index 000000000000..819005012383
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.18.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="doc examples test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=sys-apps/dbus-1.8:=
+ >=dev-libs/glib-2.40
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ') )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}] )
+"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ use doc && python_setup
+ local SPHINX_IMPL=${EPYTHON}
+
+ configuring() {
+ local myconf=(
+ --disable-documentation
+ )
+ [[ ${EPYTHON} == ${SPHINX_IMPL} ]] &&
+ myconf+=( --enable-documentation )
+
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ use examples && dodoc -r examples
+}