summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /dev-python/dbus-python
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest2
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.6.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index ddac156c42c3..257d89ebbe45 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,5 +1,7 @@
DIST dbus-python-1.2.0.tar.gz 602426 BLAKE2B 86f5ba9283256b83d268ff7c27368e587896d58f87b15aefe9d29a90530ced591a2c6814dd37b91274910ed131fe031846071311bc6cc07c11d1f9cdda9e4602 SHA512 013b23e08fa1ed43f53a756587fefbc9770f7c51e93510e555acbd77230b7200693419bba9a69680d790bbaf123f4a195afa38b3eee1143da950fee0b5130bce
DIST dbus-python-1.2.4.tar.gz 612112 BLAKE2B cccd3e2f5d700c0d228e7d21fd85e2307357778371742a7fe26a0e419af41886efebb27a73f642d2ecd4603c79f4afe6e7002af95c831180e0e7844c079b2c8c SHA512 efdd9d96a8b56e813c93208d34777f1ca2db96c076d31f13afbcaec3c7770a16a623d5531fe23443130c555240949802503f171f2064d45eee97546d6251304b
+DIST dbus-python-1.2.6.tar.gz 778893 BLAKE2B 1587bc9b1795e5c416397468b2061c869d923aea0983e604862342b27d37b946b1fcdd3bf07a612dba30087bdc6a5fa734906188c55756edf38d50eb67b7eef6 SHA512 6f2aec81defd2528d9876ec9a83843f8767275a5d6cf1b2b7b7a094f892f552f9a7b3d7b5006465254d410e503108e10138d7dd4cb3f1a4035d7f8d58c4d0684
EBUILD dbus-python-1.2.0-r1.ebuild 2210 BLAKE2B 0f475f5ebe65b9880a5a9807f01914f3dc366597b21d528c1642d251400710a9dcd45f0bac1cd7e1faafa4506b358bc4d723d5c87d1db05dddec74eede59fa3a SHA512 a7bd731d00b142fdd0dcc90c8c2b3e87ad4766ca4725cf10d2418b13de82e87df1931cb76fa40e1808fe0a8d1be3012e855e126f0b398f5aaa308118a67a9c0a
EBUILD dbus-python-1.2.4.ebuild 2229 BLAKE2B 306760812025ff7684666d7d585b6c72391ac3f5bf0b3562784b0b90394950fba905033bfc12d68f09136aa98178c65a704e9e125df0491a0d2fc98fe90cb3e1 SHA512 591ea483d5f3ba0dcd818b04bd2f8a6282e98e84a83e7631f75b38b06249e6b4820d40affb4990940a6d5c968dd94bb155c232fca47e65ceb63545027d467b3f
+EBUILD dbus-python-1.2.6.ebuild 2259 BLAKE2B 0a844ba8e2215dde83e8ea7286c619981aac5dbf43ce710c4832e8a99f691efc15e13c9587ce4f3166f7aa0e0916fbf199d556b87f62f063eb679b2032981c7b SHA512 65c46dae5970b6883897d8dc56ba6bd939abbb1af581dd7b9d93b9ee58ae4193ee01a294958c017a59bea6c182006220f7241e72df0455f41b39418834a7e1e5
MISC metadata.xml 337 BLAKE2B 96d3f5d7c37edb1a63791e013c39cf5b10c94d621ad851f9975d9d5e36519da135bf963f2a0e38c2c098fa48c2056bf210bdfcebc12bb10a88c9e9f85c55eb2a SHA512 633761250e946af99fcbcbf813b70fa0b1e03a0d89102faa3f324c418f0e749371aa931d253dc5a6f69369c25acc2d50a0f5e2155bd727766bc70f4bc3933d65
diff --git a/dev-python/dbus-python/dbus-python-1.2.6.ebuild b/dev-python/dbus-python/dbus-python-1.2.6.ebuild
new file mode 100644
index 000000000000..169ee6c62d28
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools eutils python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="doc examples test"
+# API docs generated with epydoc, which is python2-only
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ doc? ( python_targets_python2_7 )"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.108:=
+ >=sys-apps/dbus-1.8:=
+ >=dev-libs/glib-2.40
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ dev-python/docutils[python_targets_python2_7?]
+ =dev-python/epydoc-3*[python_targets_python2_7?] )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ configuring() {
+ local PYTHON_CONFIG
+ python_export PYTHON_CONFIG
+
+ # epydoc is python2-only, bug #447642
+ local apidocs=--disable-api-docs
+ [[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-html-docs \
+ ${apidocs} \
+ PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
+ PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
+ # configure assumes that ${PYTHON}-config executable exists :/
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ default
+ [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
+ }
+ python_foreach_impl run_in_build_dir installing
+ prune_libtool_files --modules
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}