summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-python/dask
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.4.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 68ae0769df03..c042aa64c69f 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,5 +1,7 @@
DIST dask-2023.3.2.gh.tar.gz 8525841 BLAKE2B 660f3687320c0d56abe437bf7edea2f40fe624a3f48761238b00756f61358d73d47a570399ed70f6f1f2188cb03b04fc10e5c9683e2a49c6b73a21c35173e1dc SHA512 ef1a961a50e69a32aea14630e9d19fc92646e9f520fa265937bb923aeba5932397840b2971bfb9a47125672ac2bd9b0b6a017b650708a183b3bf6c0c345e2af2
DIST dask-2023.4.0.gh.tar.gz 8511473 BLAKE2B 3b6a4e07e0ddc1a40b9494089250e80254b16002c18b091911aa007e1e455f146a192e5f8f9c49b5cf73bc60d942429e1d5ff399516f2b81120ae8f4d79b1dbb SHA512 40071fc3f5597312af28a5c545ebb14d2e2aa3d1a3a0a5d81d335fce3a7a8e7036c900a1caa43f84f76335c469b1bf138f662588f0d015943c4a4bf931c20349
+DIST dask-2023.4.1.gh.tar.gz 8514681 BLAKE2B 5bdf8e81692f16b16f3c38ac45e309f73bf85b51aa3c2d9edaae36dc1d43b96a91a8f79e5219ea2a380d26f75c0954dec507b5913b74fdfabe691b340656c75f SHA512 e640ec2bb532dd2723db1c51a023b62aba1198a393beea8eec359f47388a2a42e7a0fe20d06f393ba0538b86fe2f6e0d29eb00eada9cf4ca22acc45b80062dc9
EBUILD dask-2023.3.2.ebuild 2114 BLAKE2B 0eb051821a2de52ec53806bcbbc58b6ffa0dc41cdca6047d7192f5a2deec78f0d05dce895dc50faba89bf1d60df2c9c3d1d9985794953b339edfffe7e2c2fe1c SHA512 c11268c3ed784133b2ad4ac01d2f396fe6e3895dbf822200400119b01f892371d116f50242ea890035148f80abff36d0d0dd73fd7e16c6939d2a1aa3e7853a85
EBUILD dask-2023.4.0.ebuild 2210 BLAKE2B 1e5d7d7d40ee193b7a880426351bd7775145b98b52d1be54add8de36b4306ff0c82bc5ca5e5da551e7d31784a92dfe783343c3c14cdcf6e90b17332af516570a SHA512 aaf9967b121ff8649535283494a67ed5a08de1faea47aa86d1fec1299a54f3a74dd7dcab5bf25d5ffd583892784d9b491c5624ba4ea5306e21464219582b868a
+EBUILD dask-2023.4.1.ebuild 2330 BLAKE2B 8660ab59bf0e4986d1fe8ca91eff6df5e291ce8cb68a1aea251529c2336aa2df1906f9640cb9f343972c9d6e5066b5ce0b6dc1e3358f42ff215d1449403b30ae SHA512 414e5827b28bf5fa4d9c11e1180957720c22dad014de7d8b7724e60a3cabea0ec2f938de1b31dabb93438524291860cefadb772f03dfbb0b276416b8f8679390
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.4.1.ebuild b/dev-python/dask/dask-2023.4.1.ebuild
new file mode 100644
index 000000000000..555d07273c87
--- /dev/null
+++ b/dev-python/dask/dask-2023.4.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+)
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}